I would like to erase the existing operating system and install Ubuntu on my Macbook6.1.

I am following this tutorial to create a bootable USB device. But my USB stick does not appear as bootable device in Apple's 'Startup Manager' on step 7.

I set the format to MS-DOS (FAT) and the scheme to GUID Partition Map when preparing my USB stick on step 3.

I tried with the 18.04.1 and the 12.04.5 releases, and I tried using Etcher (as in the tutorial) and UNetbootin to install the disk image on my USB.

I am using a mid-2014 Macbook Pro to prepare the USB stick.

  • Welcome to AskUbuntu! When you say it doesn't boot, does the mac attempt to boot it but it gives you a blank bootup screen? I.e., hold Cmd-C on power up and choose usb booting? Aug 28, 2018 at 19:17
  • @BernardWei Thank you! I mean that the USB doesn't appear as a boot option when holding the option key on power up (as seen here). The macbook boots whitout any option when holding Cmd-C.
    – tvoirand
    Aug 29, 2018 at 9:04

2 Answers 2


I finally managed to boot from the USB using rEFInd.

I found rEFInd here. I installed it in the original OS on the Macbook6.1 by running the install-refind script.

More information about refind here.


UNetbootin makes creating a bootable USB straight forward.

Warning: make sure all important data is safe before doing this!

  • In UNetbootin, browse to your disk image, select your bootable drive and click ok and wait for the installer to finish.

  • Turn off your computer and back on again while holding Option. Your bootable USB will appear as UEFI.

  • Boot in and follow the default installer (selecting 'Erase disk and install Ubuntu').

  • I tried using UNetbootin to create a bootable USB. The USB still does not appear when powering up my Macbook while holding Option.
    – tvoirand
    Aug 29, 2018 at 9:51
  • Same issue here. Mar 1, 2020 at 21:14
  • Maybe, your system uses a different key to Option? Can you navigate to the USB in your file directory and see squashfs? Are you sure the installation completed?; it should take about 15 minutes. Did you run unetbootin with su write privileges? There are a few different methods of creating a bootable USB, but I have found Unetbootin to be the most reliable/easy.
    – jackw11111
    Mar 1, 2020 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.