1

I have a old Acer Aspire L5100: https://uk.hardware.info/product/4190/acer-aspire-l5100-tv/specifications

Got it from my parents company, it had Win Vista on it. But had forgotten the password. But since I am learning about Linux and more specifically Ubuntu. I have tried Ubuntu as a dual boot. But with this one I wanted to make a Ubuntu ONLY PC!

Install story!

I try to install 17.04 - Nope will not install. (I do get Acpi error, but do not understand at this point that it is Acpi that is stopping me.)

I Try a old distro that I have, 06.04 or something. It is so old that I cant update it and most everything will not work. BUT it installs, a big pluss. Also motivates me to keep at it.

I also understand that the CD/DVD player on the PC will not accept DVD install disk, so that rules out Ubuntu image on DVD. Tried to use a DVD player from another laptop, but it starts and then stops installing.

So I try finding the LAST Distro on CD, find it and get a "half limping install". Using Shift and getting in via Recovery Mode, it "works", but I keep getting errors.

I then upgrade it from 12.04 and all the way to 18.04. But I still keep getting errors. Partly not fail?

Well... I now read everything I get that stops me and FINALLY get it that it is Acpi that is doing something bad!

I open Bios and disable ACPI, the PC starts up and stops on start screen for Acer! When restarted it have changed Bios BACK to ACPI Enabled!

Tryed to read up on Bios stuff to see if I can find a work around, so fare I do not think there is. Only to disable ACPI, but that dos not work!

I have tried to put "Acpi=off" in boot grub. Partly success, but not stable and will not start normally, only in Recovery Mode! Not even sure if I did it right! Or put it in the right place!

Also done a Terminal upgrade, partly works, but get errors! I only get in via Recovery Mode!

So... HELP!!!

I want to install Ubuntu 18.04. I can use USB as a media to install. I have used Unetbootin as one option. But I like Universal-USB-installer more. They work as a medium to install.

But the ACPI is stopping me from getting a "clean" install.

What can I do?

PS! In trying to do this I have gotten a introduction in using Terminal, but is a PURE Nub! So very new to Ubuntu and Linux, but with Win 10 I want to get away from Win permanently!

PS!! In one way this is good, learning about Linux and helping me to make a safe and good transition to Ubuntu!

  • News! Did a 14.04 install from USB image and after install I changed the GRUB and added "noapic" and then 14.04 can start without Recovery Mode. It starts with no problem. Tried the same on 18.04 - Nope, did not work! Used this as help for the 14.04 install: youtube.com/watch?v=jd9WIcPKc-o – Odd Aug 29 '18 at 18:04
  • Updating 14.04... In the feed of "Downloading, unpacking and installing", I got a messages on two things was broken. Or as the program said it, "It is a broken installation!" Tried to make a screen shoot, but even that did not work. There is a PNG file, will send it to my Dropbox and see if another program is able to show the screen shoot so I can try to fix that. It gave a solution or how to try to fix it. So... sad news... the install of 14.04 is a "limping install", yet again! – Odd Aug 29 '18 at 22:10
  • Then everything was so much updated that Ubuntu 14.04 asked me if I wanted to update to 16.04 LTS! So I did! It got worse, way worse! I never got to the clock and icons on the main screen on the first re-start. The "main" screen came up and stopped! So I did a test, downloaded Linuxmint 19. Made a USB image and installed again! In the start it told me about the Acpi problem, "Ohhh no, this dos not work!" I just sat down and relaxed and started to think, "What now? What other Linux Disto can I test?" – Odd Aug 30 '18 at 6:38
  • As I was sitting there thinking, suddenly Mint19 was started up as a "LiveCD" and appeared to be working. I got an option to install it "OK? Will THAT work? Why not try, nothing to lose!" Short story of it all! 3th install on the PC, and side by side I have Ubuntu 18.04, 16.04 and Mint19 - and Mint19 is working! Even with the Acpi error in the boot-up of "LiveUSB". Not sure what happen! Will try to find out what the differences are! So it CAN work!!! – Odd Aug 30 '18 at 6:38

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.