1

I'm using Ubuntu 18.04 and I used xmodmap to changed left Alt as "Meta_L" and bind it solely to "mod4" (meaning I did remember to remove "Mod1" from Meta_L), the end result is left Alt behaves like "Command" in Mac OS so I can use the same keyboard shortcuts of IntelliJ and Sublime Text as I do in Mac OS.

However I found out that for whatever reason, "Super + O ('Oh' not '0')" or "Super + Shift + O" binding can't produce the shortcut event. At the same time "Super + B", "Super + Shift + up" and etc. all work as expected.

I was wondering if "Super + O" is system shortcut that override the application shortcut but after some research I can't find any.

At last, I used the same technique in Ubuntu 16.04 too and every thing works as expected.

Hope someone can share their experience and idea on this, thanks a lot!

3

I ran into this problem (Ubuntu 19.10) and found this page. I was trying to use Super+O for a shortcut but it didn't work. Thanks to Anbu's answer showing gsettings I was able to figure out what was grabbing the key:

(for schema in $(gsettings list-schemas); do gsettings list-recursively $schema; done) | grep '<Super>o'

It showed org.gnome.settings-daemon.plugins.media-keys rotate-video-lock-static ['<Super>o'] so I removed it with

gsettings set org.gnome.settings-daemon.plugins.media-keys rotate-video-lock-static []

I restarted and was able to use the key again. I found lots more unwanted bindings with

(for schema in $(gsettings list-schemas); do gsettings list-recursively $schema; done) | grep '<Super>'

and then removed them with gsettings set …

1
  • Hey thanks for the reply, have mark yours as the solution. – Shawn Lu Nov 9 '19 at 17:54
0

I did fresh install recently and was able to map Super+O without issues with xbindkeys. Create a file ~/.xbindkeysrc with

"your command here"
 Mod2+Mod4 + o

And execute:

xbindkeys -f ~/.xbindkeysrc

However I had issue with Super+p which was resolved by disabling default key binding for switching monitors:

gsettings set org.gnome.mutter.keybindings switch-monitor=['']

That was a little tricky because "dconf dump" doesn't mention it while "gsettings list-recursively" does.

So, you may check your system keybinding and clean them up before using xbindkeys to change them.

Here are dotfiles where it works.

-1

I end up re-installing 16.04 LTS and everything works as expected.

3
  • Wow, that's disappointing. For me going back to 16.04 is not an option. I have the same problem and would love a solution working for Ubuntu 18.04 – zwolin Sep 25 '18 at 14:33
  • Good to know there is other people who uses the super key that way. I'll wait for some Ubuntu guru to append his solution and see if I can upvote that answer. – Shawn Lu Sep 27 '18 at 4:07
  • Yeah, it is so weird though, that I can register quite a lot combinations of Meta/Super + something except Meta/Super + O. What's up with that O? So curious!:D – zwolin Sep 27 '18 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.