2

After upgrading from 16.04 to 18.04 I can't find a way to use the nvidia-settings either via command line or GUI.

When I run sudo nvidia-settings I got the following message :

No protocol specified
Unable to init server: Impossible de se connecter : Connexion refusée

ERROR: The control display is undefined; please run `nvidia-settings --help`
       for usage information.

ubuntu-drivers devices produces :

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C8Dsv000017AAsd000039D1bc03sc02i00
vendor   : NVIDIA Corporation
model    : GP107M [GeForce GTX 1050 Mobile]
driver   : nvidia-driver-396 - third-party free recommended
driver   : nvidia-driver-390 - third-party free
driver   : xserver-xorg-video-nouveau - distro free builtin

The command prime-select query outputs : nvidia

First I tried to install the drivers with :

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt install nvidia-driver-396

Then I tried

sudo apt purge nvidia*
sudo apt update
sudo apt upgrade
sudo ubuntu-drivers autoinstall

but no changes

I remember that in 16.04 I used a proprietary driver. But now there is no proprietary driver that I can select : software and updates

Let me know if any additional infos or command output could help to solve the issue.

I also have ukuu (ubuntu kernel update utility) and have the kernel up to date with the last version.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.