22

As the title suggests, I am experiencing issues with my Display in Ubuntu 18.04. I have seen somewhat related posts (like this one), but those typically suggest they have several detected displays, where one of them is dubbed 'Unknown Display'.

Well, I only have a single display called 'Unknown Display', which means I:

  • cannot add a second/third/etc screen,
  • cannot adjust the resolution,
  • and cannot adjust the brightness

I would very much like to be able to do the above, obviously, and I was hoping somebody over here might be able to help me out. I have tried out several things, like removing the current drivers in favor of older ones, but I seem to be missing something crucial every time..

Here are some specifics about my system:

  • I am running Ubuntu 18.04.1 LTS.
  • I have a GP107M [GeForce GTX 1050 Mobile] graphic card.
  • I have nvidia-driver-396 installed.
  • It is a dual boot system, where I left the original Windows copy intact.

Some potentially interesting stats:

lspci | grep VGA output:

steven@stevens-laptop:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1

xrandr output:

steven@stevens-laptop:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
   1920x1080     77.00*

nvidia-settings output:

steven@stevens-laptop:~$ nvidia-settings
ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

If any additional info is needed to figure out what's going on, please let me know. And thanks in advance for any help on this!

Here is a screenshot of the 'Settings -> Devices -> Displays' window in my Ubuntu by the way: display-settings

2
  • Steven, I do have the same issue, did you get a perfect solution for this problem?? – Anoop Sankar Mar 13 '20 at 9:34
  • 1
    Sorry to disappoint you @AnoopSankar, but I haven't managed to fix this problem at all... I am however pretty confident it's the lack of support on Acer's, the laptop I was using, in my case. I eventually just gave this computer to another employee and bought a different one (sad but true...). Two of the provided answers did help out others though, so maybe those will solve your problem. – Steven Mar 17 '20 at 8:29
20

I had this problem and removing the monitors.xml config didn't work.

there was a problem w/ the nvidia driver. check to see by running

ubuntu-drivers devices

and if that looks good

sudo ubuntu-drivers autoinstall

should do the trick

https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux

7
  • Although this originally didn't work, I reinstalled 18.04 recently (with the same screen issues still in place, mind you) and now my NVidea Settings do work! So, one step in the right direction, but now my second screen is still not being recognize :[ Nonetheless, the help is much appreciated @Even W! – Steven Dec 20 '18 at 8:37
  • To be more exact, the message I now receive when running nvidia-settings is the following: ``` steven@steven:~$ nvidia-settings ERROR: NVIDIA driver is not loaded ERROR: Unable to load info from any available system (nvidia-settings:2986): GLib-GObject-CRITICAL **: 09:57:33.804: g_object_unref: assertion 'G_IS_OBJECT (object)' failed ``` – Steven Dec 20 '18 at 8:58
  • 1
    The autoinstall + reboot worked perfectly for me. – Opsse Jan 31 '19 at 12:52
  • This saved my day – Forever Feb 18 '20 at 0:15
  • 2
    Ubuntu 20.04... still works! I think what happened is an apt upgrade caused a new initrd image to be created that was booted from, and it had the wrong graphics properties set. I ran the commands above, then made sure to run sudo update-grub, and then cat /proc/cmdline to verify the initrd image matched, then rebooted... and all my monitors came back online with expected resolutions. – Brian Vanderbusch Nov 11 '20 at 13:56
6

I fixed this issue by deleting the configuration file (resetting) for the display settings:

rm -rf ~/.config/monitors.xml
3
  • Thanks for that Dustin! I had 3 monitors*.xml files in my ~/.config/ directory, all with some weirdness in it. Removing them however did not do the trick... Nonetheless, the response is much appreciated of course. – Steven Sep 8 '18 at 10:56
  • omg, this deleted everything on my desktop. And my Firefox bookmarks. – mLstudent33 Dec 24 '20 at 8:43
  • I copy pasted and added <disabled> section: <configuration> <logicalmonitor> <x>0</x> <y>0</y> <scale>1</scale> <primary>yes</primary> <monitor> <monitorspec> <connector>default</connector> <vendor>unknown</vendor> <product>unknown</product> <serial>unknown</serial> </monitorspec> <mode> <width>1920</width> <height>1080</height> <rate>77</rate> </mode> </monitor> </logicalmonitor> <disabled> <monitorspec> <connector>eDP</connector> <vendor>BOE</vendor> <product>0x0812</product> <serial>0x00000000</serial> </monitorspec> </disabled> </configuration> to monitors.xml – Alexander Glulkhovtsev Apr 24 at 10:09
1

I just had this problem - all of a sudden, when I booted the computer this morning, my Samsung 40" TV had turned into "Unknown Display" and I have no idea why.

Then I found this question and tried to debug according to the first answer - so after lspci I ran xrandr and suddenly boom!, it worked!

I still have no idea why, but I suspect it could be a kernel (i.e., a missing kernel update) thing.

1

I think this is for the one's who didn't solve there issues by the above suggestions.

I got the same. I just changed the grub file

sudo vim /etc/default/grub

and changing the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

This fixed my issue. Please upvote if you find it helpful.

Not the answer you're looking for? Browse other questions tagged or ask your own question.