5

I've installed Ubuntu 18.04, and everything worked excellent until I decided to try Unity desktop. Bottom line - I've uninstalled unity desktop completely. But! I have some stuff that didn't recover to previous state. First is the login screen that have changed, and I want to bring back the gnome native login screen.

Second is the Lock screen (that is shown on wake up). Before unity it was the gnome's one, that you can change it's background in the background properties.

After unity it changed to annoying login form that doesn't work if the keyboard layout is not english, and you just can't switch between layouts in this form and all the window around it. So if before sleep I was using hebrew or russian layout, on wake up I just cant log back in, and I have to restart the pc.

How can I switch back to normal gnome stuff? Thanks!

1

Issue the command

sudo apt install --reinstall ubuntu-desktop

At some point, you will be asked which display manager to use. The gdm display manager is the default for gnome. After installing Unity, you have switched to lightdm.

After logging out and logging back into the default Ubuntu session with the gnome desktop, you can remove the unity session by uninstalling "unity-session":

sudo apt purge unity-session

Further cleanup may be obtained by autoremove:

sudo apt autoremove

This removes all packages that were automatically installed to satisfy dependencies for "unity-session".

  • Nothing changed.. Previously I already removed unity-session, but not "sudo apt install --reinstall ubuntu-desktop". My question came after that. Now tried reinstalling ubuntu desktop, nothing happened. Than again (to be sure) tried to purge unity session + autoremove, still nothing. – Valenstein Aug 29 '18 at 18:30
0

Well I managed to solve it, by guide on the other website. Don't know if I'm allowed to post external links, so I'll try to describe the process here:

Step 1

sudo systemctl disable lightdm && sudo systemctl enable gdm

lightdm was disabled, but I had trouble to enable the gdm for some reason. I decided to reboot, and entered the dark world of pure terminal.

Step 2

I had no idea what the following code actually does, but I kept trying.. a lot of stuff. But the finalists are these:

sudo ln -sf /lib/systemd/system/gdm.service /etc/systemd/system/display-manager.service
sudo systemctl enable gdm
sudo systemctl set-default graphical.target

Thank for help!

0

I took a slightly different path. The key point was that I first switched the display manager from lightdm to gdm3 with

sudo apt-get install gdm3
sudo dpkg-reconfigure gdm3

I mostly followed the answers from this question: How do I switch from LightDM to GDM?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.