0

I just installed ubuntu server 18.04 and i'm getting this error when I install webmin by using sudo apt install webmin :

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 webmin : Depends: libauthen-pam-perl but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

marked as duplicate by karel, N0rbert, guiverc, Eric Carvalho, Fabby Aug 29 '18 at 19:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • try install manually the dependency with sudo apt install libauthen-pam-perl webmin – damadam Aug 27 '18 at 9:46
  • Yes I tried and I got The following packages have unmet dependencies: libauthen-pam-perl : Depends: perlapi-5.22.1 E: Unable to correct problems, you have held broken packages. – Neuvill Aug 27 '18 at 9:51
  • And I get this when i try to install perlapi-5.22.1 manually Package perlapi-5.22.1 is a virtual package provided by: perl-base 5.22.1-9ubuntu0.5 [Not candidate version] perl-base 5.22.1-9 [Not candidate version] knowing that perl-base is already installed but in a newer version version (5.26.1-6ubuntu0.2) – Neuvill Aug 27 '18 at 9:53
  • do you have installed libperl-apireference-perl? It can solve this problem with perlapi-5.22.1 – damadam Aug 27 '18 at 9:55
  • 1
    try a sudo apt install -f – damadam Aug 27 '18 at 10:02

Browse other questions tagged or ask your own question.