I have a HP Pavilion Laptop. The details of which, obtained by running the command lshw, are below:

product: HP Pavilion Notebook (N1J39EA#A2N)
    vendor: Hewlett-Packard
    version: Type1ProductConfigId
    serial: 5CD5291DWT
    width: 64 bits
    capabilities: smbios-2.8 dmi-2.8 smp vsyscall32

I switched from windows to Ubuntu 18.04 very recently. Initially I did face wifi weak signal issue. However, I fixed the issue by using the following commands:

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2
sudo ip link set wlo1 up
sudo iw dev wlo1 scan
echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

Everything was working perfectly and then 2 days ago I updated my system and thereby the kernel got updated which in turn brought back wifi issue.

I tried to fix wifi issue by using the same old method but failed to do so. I also tried the following:

sudo tee /etc/modprobe.d/rtl8723be.conf <<< "options rtl8723be ant_sel=1"

which also couldn't solve the issue. Then I went on to try the following:

sudo -i
echo "options rtl8723be ant_sel=2"  >  /etc/modprobe.d/rtl8723be.conf

the same result with same problem. output of the command

lspci -knn | grep Net -A3; rfkill list

is as follows:

08:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 0a)
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no


Weak Signal

inconsistent connection

weak signal and disconnection

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.