1

I made sure to

  • check /etc/gdm3/custom.conf to make sure that WaylandEnable=false was commented out.
  • be on the latest Nvidia driver (390).

When I click the cog icon on the login screen to change the session type, I don't see the Wayland option. Is there a way to get it? I'm really looking forward to 150% scaling.

  • Was the "Ubuntu on Wayland" session there before you installed the Nvidia drivers? – user639089 Aug 27 '18 at 7:50
  • This was an upgrade from 17.10 so I'm not sure – Hassan Aug 27 '18 at 14:03
1

Try again, you may be offered the choice now.

I noticed in Sept. 2018 that the Wayland option under the gear icon at login was offered and worked on my laptop running Ubuntu 18.04 with the Nvidia 390.48 drivers. After the initial installation of 18.04 in May, the Wayland option was not offered, but after some update, that changed. Try again, you may be offered the choice now.


I just noticed that maybe all that happens is that the switch to the Intel drivers has been implemented. The Settings/Details/About show the Intel Sandybridge for Graphics. lshw -c video shows both.


For my Ubuntu 19.10 install, Wayland is not offered if the Nvidia proprietary drivers are installed. The automatic switch to the Intel drivers was removed, as was the Wayland login option.

  • there are specific graphic drivers which will not support wayland and wayland is not that stable, Xorg is alot stable currently – Jatin-CBS Sep 27 '18 at 23:07
  • Still didn't work for me, just checked it. What drivers don't support Wayland, @Jatin-CBS? I'm just using the proprietary drivers through Ubuntu's repos. – Hassan Oct 5 '18 at 2:03
  • On your hardware wayland may be offered but when you login to wayland you'll be using intel not nvidia. – doug Mar 12 at 21:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.