1

Before you mark this as the same thing as the others, You need to know I have done this before hundreds of times with no problem, I just reinstalled Ubuntu 18.04 2 days ago, and I was trying something with Minecraft and tried to open the optifine download, which is a jar file, and it wont do anything I tried running it in terminal and this is what I got

Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper` 

I had installed Java the same as I always had no problems, but this time is different. All help is appreciated.

marked as duplicate by karel, muru, N0rbert, Melebius, Eric Carvalho Aug 27 '18 at 15:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Are you using the openjdk-8-jre? If you have openjdk-11-jre or similar installed, you're going to have a lot of breakages for Optifine and Minecraft. – Schyken Aug 27 '18 at 7:43
  • 1
    I got it to work. I had jdk 11 on it and I think it was conflicting with 8. I just remove everything involving java and reinstalled and it worked – Jeffrey Kratka Aug 27 '18 at 15:57
  • Awesome! Glad it helped! (I had the same issues myself, so I figured I wasn't alone.) – Schyken Aug 27 '18 at 17:55
0

Disabling the assistive technology may do the trick :

sh sudo sed -i "s/^assistive_technologies=/#&/" \ /etc/java-11-openjdk/accessibility.properties

Remark : use the right property file for your config, here it is for openjdk v11.

  • It just started crashing on startup, So now I think disabling broke it. Minecraft Runs without it though, so its not the game, Its Java i think – Jeffrey Kratka Aug 27 '18 at 6:05
0

Try adding the atk wrapper to the classpath

export CLASSPATH=/usr/share/java/java-atk-wrapper.jar
  • Not deleting this answer because it is listed as a workaround on the openjdk bug and does work for some instances of the atk wrapper bug, so it's worth remaining for some people that hit this page. – nobody special Aug 27 '18 at 23:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.