I had recently updated to Ubuntu 18.04. All was working fine until today morning when I was not able to connect to the wifi. When I try to scan for networks it shows no networks found. When I run iwlist wlo1 scan I get the following results:

wlo1 No scan results

I had the same problem with Ubuntu 16.04 but managed to fix by changing the antenna_sel parameter as per this and this by using:

sudo modprobe -r rtl7823be 
sudo modprobe rtl8723be ant_sel=x

The value of x being either 1 or 2, whichever gives better results for wifi signals. However, when I try the same solution for 18.04 it doesn't seem to work. I have looked for solutions for 18.04 and found this answer this answer. There deosn't seem to be any conclusive answer on how to fix the problem. I decided to uninstall rtl8723be drivers using sudo apt purge rtl8723be and reinstall using this however when I try to do that I get errors (when I run this command sudo add-apt-repository ppa:hanipouspilot/rtlwifi) such as:

E: The repository 'http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

I then installed the rtl8723be driver using instructions as per the github page for rtlwifi_new in here. The installation was sucessful however I was back to square one, no wifi networks found. Does anyone know how to get the wireless to working? I'll post the output of lshw -class network below:

   description: Wireless interface
   product: RTL8723BE PCIe Wireless Network Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:08:00.0
   logical name: wlo1
   version: 00
   serial: 70:77:81:12:fc:2d
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-33-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
   resources: irq:18 ioport:5000(size=256) memory:c6100000-c6103fff

   description: Ethernet interface
   product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:09:00.0
   logical name: eno1
   version: 0a
   serial: 3c:a8:2a:ae:31:82
   size: 100Mbit/s
   capacity: 100Mbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8107e-2_0.0.2 02/26/15 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
   resources: irq:19 ioport:4000(size=256) memory:c6004000-c6004fff memory:c6000000-c6003fff

PS: The LAN works just fine, the problem is just with the wireless interface.

EDIT: The problem is solved with an update to 18.10 as it uses kernel 17.0.


I am afraid I don't have an exact answer to your question, but I am having the exact same problem and found a workaround to get my wifi running on my laptop again.

Run in terminal: uname -r
Does it say 4.15.0-33-generic?

My solution:
When booting the laptop, select advanced startup options (as if you were trying to select recovery mode) and select kernel 4.15.0-32-generic.
(When entering this menu, I had multiple options/kernels to choose from - some were listed as (recovery mode) and others were normal - I chose the non-recovery entry.) I will try to google my way to a better fix and post back if I find it.

  • Wow! That worked, wifi is working again! Thanks! – srikarad Aug 28 '18 at 10:00

Try some basic: Plug wifi dongle in a different usb port. make sure you have the latest version of the following installed: linux-headers-generic build-essential git. Try putting your module in etc/modules to load at boot. Verify module is not in the blacklist file. Make sure your on the latest release of 18.4 Apt-get update & upgrade. Bring down your network manager then restart it.


  • Tried all of it, unfortunately, nothing worked! However, the solution by @Evros of changing the kernel from 4.15.0-33-generic to 4.15.0-32-generic in the advance options worked! – srikarad Aug 28 '18 at 10:03

The bug is fixed with this kernel:


as long as you select antenna 1:

modprobe rtl8723be ant_sel=1

Make sure you have that in config too:

sudo /bin/sh -c 'echo "options rtl8723be ant_sel=1" >> /etc/modprobe.d/rtl8723be.conf'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.