0

Today bought Wi-Fi USB adapter D-Link DWA-131. It does not worked "out of box". Tried solution from Install DWA-131 WiFi dongle driver under Ubuntu 14.04.4 - does not helped too.

Here is end of dmesg, hope it is significant:

[ 3548.951789] usb 1-5.2: new high-speed USB device number 7 using xhci_hcd
[ 3549.052123] usb 1-5.2: New USB device found, idVendor=2001, idProduct=3319
[ 3549.052133] usb 1-5.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3549.052138] usb 1-5.2: Product: Wireless N Nano USB Adapter
[ 3549.052144] usb 1-5.2: Manufacturer: Realtek
[ 3549.052148] usb 1-5.2: SerialNumber: 00e04c000001
[ 3549.053281] usb 1-5.2: This Realtek USB WiFi dongle (0x2001:0x3319) is untested!
[ 3549.053288] usb 1-5.2: Please report results to Jes.Sorensen@gmail.com
[ 3549.123642] usb 1-5.2: Vendor: Realtek
[ 3549.123646] usb 1-5.2: Product: Wireless N 
[ 3549.123648] usb 1-5.2: Serial: no USB Adap
[ 3549.123651] usb 1-5.2: rtl8192eu_parse_efuse: dumping efuse (0x200 bytes):
[ 3549.123654] usb 1-5.2: 00: 29 81 00 7c 01 40 03 00
...
[ 3549.123784] usb 1-5.2: 1f8: ff ff ff ff ff ff ff ff
[ 3549.123788] usb 1-5.2: RTL8192EU rev B (SMIC) 2T2R, TX queues 3, WiFi=1, BT=0, GPS=0, HI PA=0
[ 3549.123792] usb 1-5.2: RTL8192EU MAC: 18:0f:76:09:dc:de
[ 3549.123795] usb 1-5.2: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
[ 3549.267433] usb 1-5.2: Firmware revision 19.0 (signature 0x92e1)
[ 3550.737563] rtl8xxxu 1-5.2:1.0 wlx180f7609dcde: renamed from wlan0
[ 3550.793700] IPv6: ADDRCONF(NETDEV_UP): wlx180f7609dcde: link is not ready

Will be very gratefull for any help on this trouble.

UPD: Here is diagnostic output requested by chili555:

$ lsmod | grep rtl
rtl8xxxu              122880  0
rtl8188ee              94208  0
rtl_pci                32768  1 rtl8188ee
rtlwifi                77824  2 rtl_pci,rtl8188ee
mac80211              778240  4 rtl_pci,rtl8188ee,rtlwifi,rtl8xxxu
cfg80211              622592  3 mac80211,8192eu,rtlwifi

$ dmesg | grep wlx
[11931.764451] rtl8xxxu 1-5.2:1.0 wlx180f7609dcde: renamed from wlan0
[11931.966937] IPv6: ADDRCONF(NETDEV_UP): wlx180f7609dcde: link is not ready

$ rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
4: phy4: Wireless LAN
        Soft blocked: no
        Hard blocked: no
10
  • Please edit your question to add the result of three terminal commands: lsmod | grep rtl and also: dmesg | grep wlx and also: rfkill list all
    – chili555
    Aug 26 '18 at 16:36
  • @chili555, done Aug 26 '18 at 18:03
  • Hard blocked:yes usually means that the airplane mode switch is set to disable the wireless radio. Please find it and switch it on. We will still have a step or two to take, but nothing works properly with the radio turned off.
    – chili555
    Aug 26 '18 at 18:05
  • @chili555, strange, but according to KDE interface, airplane mode was switched off... Retoggled it to make it off again, but rfkill shows same result. Tried hardware key with airplane sign, it makes soft block enabled or disabled, but does nothing with hardware block. Also - what if this phy0 refers to integral Wi-Fi card in my laptop which I also could not get to work? Aug 26 '18 at 18:21
  • What computer manufacturer and model?
    – Jeremy31
    Aug 26 '18 at 18:23
1

You have several possibly conflicting drivers loaded. The driver rtl8xxxu should drive the USB well. Let's blacklist all others and see if the USB now works as expected. From the terminal:

sudo -i
echo "blacklist rtl8188ee"  >>  /etc/modprobe.d/blacklist.conf
echo "blacklist 8192eu"  >>  /etc/modprobe.d/blacklist.conf
exit

Reboot and tell us if there is any improvement.

2
  • Unrelated to this question, but I have something you might find useful for your solve all realtek problems superanswer with luis. Couldn't ping you in chat b/c you haven't been there in a while. Aug 26 '18 at 18:50
  • @chili555 I gave up with this issue and missed your answer, but now after years I returned to it with fresh installed Ubuntu on same old laptop, blacklisted rtl8188ee and Wi-Fi works now, thank you very much! Aug 10 at 10:12
0

This worked for me! I'm using ubuntu 18.04 and the D-link DWA-131 Ver E1 wifi usb adapter.

https://github.com/Mange/rtl8192eu-linux-driver

0

It works out of the box for me, but I cannot connect to any Wi-Fi networks.

Try enabling XHCI Handoff and EHCI Handoff in BIOS settings.

Set regdomain to the proper country with,

iw reg set <US/CA/IN/etc>

Set disable random MAC scan,

sudo nano /etc/NetworkManager/NetworkManager.conf

Write the following lines,

[device]
wifi.scan=rand-mac-address=no

Following these worked for me on Xubuntu 20.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.