3

They successfully connect via bluetooth and when I test the sound from the settings, both sides work. However, when I try to listen to something on the internet (with firefox), I hear nothing.

I tried the solutions to this question, they didn't work. I also tried using alsamixer - Master is currently set to 100, Headphone to 78, and PCM to 85 - still doesn't work.

Any suggestions would be appreciated.

  • 2
    Run pavucontrol, if necessary, install it first. When you play something, can you set the output to your BT device on the "output devices" tab? – emk2203 Aug 30 '18 at 11:10
  • @emk2203 I've run pavucontrol, the device does show up in the output devices tab, I have the port set to "Headset (plugged in)", and the volume is turned up. I can actually hear system sounds through the headset, I think the problem is with firefox. – Eben Cowley Sep 6 '18 at 1:59
1

This is most likely not a problem with your headphones but the app.

Go to Settings > Sound > Applications > check the sound level for Firefox

Also try other apps like Rhythmbox or something, see if that works. If it does then you've narrowed down the problem specifically to your browser.

  • Well the volume for firefox is turned all the way up, but its not playing anything. I realized that it is specific to firefox though because i can hear the sound effect the system makes when I adjust the volume. – Eben Cowley Sep 2 '18 at 19:31
  • Turn up the volume of whatever you're watching? The Youtube video or whatever? Try different types of sound eg. a Steam store page video and see if you get sound from that. – JimDeadlock Sep 2 '18 at 19:52
  • 1
    did you try pavucontrol from @emk2203's comment on your question? I've run into this before and sometimes the Settings application doesn't expose everything you need to patch audio around – Mike Hardy Sep 3 '18 at 19:02
  • @MikeHardy yes I did, maybe there's a setting in pavucontrol that I'm not noticing, but I'm pretty sure the problem is with firefox. – Eben Cowley Sep 6 '18 at 2:05
1

https://gist.github.com/pylover/d68be364adac5f946887b85e6ed6e7ae script may help you. But it's not tested on 18.04, please let me know if worked.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.