I am using HP 15-ac173TU with a wireless chipcard from Realtek, rtl8723be. I was using Ubuntu 16.04 before and also encountered this problem and solved it using this answer.

Now when I have cleaned installed 18.04(due to some problems, I couldn't update from 16.04), it is blocking me when I try to run this command:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi

which gives me the output as:

Err:8 http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic Release     
404  Not Found [IP: 80]
Reading package lists... Done 
E: The repository 'http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I am guessing that Pilot6 hasn't issued any release for bionic of this driver, and so I am getting this 404 error. I have also tried using this command:

echo "options rtl8723be ant_sel=2"  | sudo tee /etc/modprobe.d/rtl8723be.conf

and making a .conf file in the directory but still, it isn't helping me as the signal is very low.

I have installed Ubuntu in dual boot with Windows, although, when I am using Windows there isn't any problem as in Windows it chooses the antenna by itself.

I just want to know that is there any other way that I can rectify this problem and use my wireless without doing this. I have also seen this GitHub repository, but he clearly states that as I am using Ubuntu my APIs are modified. Hence, I couldn't use it.

I have researched and got this answer also, but it didn't make any sense doing it as I don't have any driver as mentioned in the answer.

I have done practically everything but still am getting this problem. Hope anyone in the community is kind to help me with this.

Thank you.

  • To continue using the system consider removing obsolete PPA with sudo add-apt-repository -r ppa:hanipouspilot/rtlwifi. – N0rbert Aug 26 '18 at 9:24
  • @pomsky After I tried ant_sel=1 instead of ant_sel=2, the iwconfig command gives the Bit rate = 7.2 mb/s which in contrast with the later gives 72.2 mb/s – thegeekbong Aug 26 '18 at 10:03
  • @N0rbert I have already done that and tried to add the PPA again but it showed the same error. – thegeekbong Aug 26 '18 at 10:04
  • 2
    Possible duplicate of Wifi networks not found ubuntu 18.04 with rtl8723be. It seems kernel v4.15.0-33 has a bug. Alternatively, try this: askubuntu.com/questions/1068826/… – pomsky Sep 2 '18 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.