6

I need multiple calculators at the same time. But when I click on the calculator icon it just refers to the one that is already opened.

How can I do this in Ubuntu 18.04?

7

Open a new terminal, then execute the following command gnome-calculator

  • Not too practical but solve the problem. Maybe I should request it as a feature in future releases. Thanks @ducvd. – rmetra Aug 26 '18 at 0:19
24

My answer here has only been tested in Ubuntu 18.04 with gnome-calculator version 3.28.0 and does not apply to older versions of Ubuntu / gnome-calculator which I don't have access to the app to verify. However, in the NEWS of the source file for gnome-calculator it states:

Overview of changes in gnome-calculator 3.23.1

  • Add new window appmenu entry bgo#724478 (Robert Roth)

So, my guess would be that any version newer than the version listed above the keyboard combination below should have worked fine.

You can try Ctrl+N for New Window which should keep opening new instances. If not you can follow below:


Once in the gnome-calculator app, you should be able to click the icon in the upper left corner and choose New Window which will open another instance of the calculator:

enter image description here

enter image description here

In the GNOME Desktop, the app menu is on the bar, but it is the same way to launch multiple calculators. Click on Calculator in the top bar and choose New Window:

enter image description here

enter image description here

  • This should be the accepted answer. Much easier than opening the terminal and typing gnome-calculator. – WinEunuuchs2Unix Aug 26 '18 at 18:25
  • If you're running Ubuntu, you should know how to run a simple terminal command anyway. – Dev Aug 26 '18 at 21:44
  • This is a decent answer, and is the only proper answer given the current state of gnome-calculator. The preferred method would be the behavior that existed in Ubuntu 16.04 where a simple shift-click on the doc icon would open a new window. This behavior is needed to facilitate opening a calculator in the current workspace. – TiberiusKirk Sep 21 '18 at 14:20
4

It seems it's an intentional implementation by the developers. Almost all other applications provide an option to open a new window in the context menu (right-click menu) in Ubuntu dock while an instance is running and you can assign this option to mouse-middle-click, but Calculator application in particular doesn't provide the option at all!

enter image description here

As a hacky workaround you may try the following.

  1. Copy the launcher for Calculator (probably named org.gnome.Calculator.desktop) from /usr/share/applications/ and paste to ~/.local/share/applications/.
  2. Open the copied file using a text editor.
  3. Look for a line beginning with Actions=. If there is one, append new-instance; to it. Otherwise add the following line

    Actions=new-instance;
    
  4. Append the following lines to the end of the file and save it.

    [Desktop Action new-instance]
    Name=New instance
    Exec=gnome-calculator
    
  5. Re-login just to be sure.

Now when you have Calculator running, if you right click on its icon in the dock, you should see a "New instance" option.

enter image description here

Click on the New instance option, it should launch another Calculator.

enter image description here

  • Middle-click does not work but apart from that, great answer! – Bradzzv May 11 '18 at 14:38
1

Press the super key (to bring up the Activities overview), start typing in the name of the application you want until it is selected, then press Ctrl+Enter.

This will work for any application, including a version of gnome-calculator which does not have a "New Window" option (like mine: v3.22.3-1).

  • It seems this doesn't work with the calculator application (both snap and apt versions) on Ubuntu 18.04, but works on Ubuntu GNOME 16.04 (v3.18). – pomsky Aug 29 '18 at 7:31
  • @pomsky: interesting. I wonder whether that is a GNOME change or something Ubuntu have patched in. – Infiltrator Aug 31 '18 at 1:09
  • It's a change to gnome-calculator. See my answer. – Terrance Sep 1 '18 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.