/home/isaac/anaconda3/bin/python: Error while finding module specification for 'virtualenvwrapper.hook_loader' (ModuleNotFoundError: No module named 'virtualenvwrapper')
virtualenvwrapper.sh: There was a problem running the initialization hooks. 

If Python could not import the module virtualenvwrapper.hook_loader,
check that virtualenvwrapper has been installed for
VIRTUALENVWRAPPER_PYTHON=/home/isaac/anaconda3/bin/python and that PATH is
set properly.

How would I go about solving the above?

  • Did you set up the virtualenv(s) yourself?
    – wjandrea
    Aug 25, 2018 at 22:28
  • 1
    Would not remember. Anyways, solved it. Just needed to run "pip3 install virtualenvwrapper".
    – Isaac A
    Aug 26, 2018 at 4:27
  • OK, glad you got it sorted! Please post that as an answer (yes, you can answer your own question).
    – wjandrea
    Aug 26, 2018 at 18:46

1 Answer 1


OP solved it.

Just needed to run the following:

pip3 install virtualenvwrapper

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .