pip3 search aiohttp produces (among other things):

aiohttp (3.3.2)  - Async http client/server framework (asyncio)
  INSTALLED: 2.3.10
  LATEST:    3.3.2

Nevertheless, pip3 install --upgrade --user aiohttp responds that it's already up to date, and pip3 install --user aiohttp==3.3.2 returns:

[...] Could not find a version that satisfies
the requirement aiohttp==3.3.2 (from versions: 0.1, 0.2, 0.3, 
[... snip ...], 2.3.10, 3.0.0b0) No matching distribution found for

Python3 is v.3.5.2, and pip3 is v.18.0, which is an upgrade to the system's python3-pip v.8.1.1. Pip3 was upgraded locally using pip3 upgrade --user. See this question for links and discussion.

What am I doing wrong?


1 Answer 1


The core issue, which we debugged via chat, is that you upgraded pip. This causes some... incompatibilities (and there's terminal dumps in the chat room from a 16.04 container to support this).

Step 1: Remove the upgraded pip versions

This one's easy, since you installed it in your local data - pip3 uninstall pip

This will remove the version of it in your local userspace.

Step 2: Close your terminal or SSH session, then reestablish it.

This is so the session forgets about the local userspace pip3 binary.

Step 3: Run the installation steps again for the PyPI packages you're after - pip3 install --upgrade --user aiohttp stig (this also installs stig, too, which you mentioned in chat was your goal)

This should install aiohttp version 3.4.0 (latest in PyPI as of this post) and stig.

We did all this in chat, and it installed aiohttp without issues. The problem with upgrading pip versions is it will increase the chances that pip will not work since newer pip versions rely heavily on also having an updated Python version. And unless you are using virtualenvs for your Python environments, you're stuck on the system's Python 3.5.2, of which the newer pip does not behave with. (Note that this was also recognized during our tests).

Also note that aiohttp has a requirement listed on PyPI of Python 3.5.3 or higher. This is not going to be resolved within a 16.04 environment, so you may need to resort to Python virtual environments with more updated Python, or VMs running Ubuntu 18.04, or containers (such as LXD based containers) with 18.04. This gives you a more updated Python version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .