4

When I installed Ubuntu for the first time I had to do some work with the terminal because my Wi-Fi reception was lower than on Windows:

echo "options rtl8723be ips=0 fwlps=0 ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723be.conf

After updating Ubuntu to bionic beaver my Wi-Fi randomly stops and my browser says that I am not connected to internet. I need to turn off and on my Wi-Fi to use the network. I searched on internet and I followed instructions in this answer. Now my pc says "no Wi-Fi adapter found"

I tried doing:

sudo apt-get install --reinstall bcmwl-kernel-source

with a reboot. And I have also tried:

sudo apt remove bcmwl-kernel-source && sudo apt install git dkms
git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6

but nothing.

lshw -C network says that my wireless net adapter is unclaimed:

  *-network UNCLAIMED       
   description: Network controller
   product: RTL8723BE PCIe Wireless Network Adapter
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:02:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress cap_list
   configuration: latency=0
   resources: ioport:2000(size=256) memory:91200000-91203fff

What can I do? I am fairly new with Ubuntu.

Edit:

I have tried this answer, but it says "Unable to locate package rtlwifi-new-dkms"

  • You can gain some information by running journalctl /usr/sbin/NetworkManager --follow – waltinator Aug 25 '18 at 12:21
  • did you try sudo modprobe rtlwifi_new sir? – abu-ahmed al-khatiri Aug 25 '18 at 12:23
  • @abu-ahmedal-khatiri modprobe: FATAL: Module rtlwifi_new not found in directory /lib/modules/4.15.0-33-generic – Ken Aug 25 '18 at 12:35
  • What is the result for sudo modprobe -v rtl8723be – Jeremy31 Aug 25 '18 at 12:40
  • that drivers compatible for 16.04 at your link and uncompatible for 18.04 try this driver. – abu-ahmed al-khatiri Aug 25 '18 at 12:43
4

What kernel version are you running?

You can type uname -r in a terminal to get it

I spent long hours to figure out that the problem had something to do with the 4.15.0-33-generic kernel. I switched to the previous one (-32) and everything worked again.

However, i just managed to install the "rtlwifi_new" you mentioned, and now wifi seems to be fine even on latest one.

So, on the 33 kernel, I plugged in the eth cable and executed the following commands:

  • sudo apt-get install build-essential git
  • git clone https://github.com/lwfinger/rtlwifi_new/
  • cd rtlwifi_new
  • make
  • sudo make install

And in rc.local script I've put these two commands:

  • sudo modprobe -r rtl8723be
  • sudo modprobe rtl8723be ant_sel=1

Then I rebooted the system

Hope this can help

| improve this answer | |
  • 2
    my kernel is 4.15.0-33-generic, I executed the commands but nothing. I tried the previous kernel version (-32) and it still says no wifi adapter found, but I can switch on and off the wifi, and and I can connect to wifi, oddly it shows me a ethernet icon instead of a wifi icon – Ken Aug 26 '18 at 20:38
  • Instructions in the answer worked for me on Ubuntu 18.04 with 4.15.0-33-generic. Used master branch and options ips=0 fwlps=0 ant_sel=1 – viddik13 Aug 29 '18 at 12:01
1

That unload/reload of rtl8723be may not work. Under some circumstances, the chip remembers the ant_sel option and ignores the one set on antenna reload. The safer way is to create an options file in /etc/modprobe.d/ that sets the ant_sel option.

Also be aware that there have been changes in the btcoex code that changed the best value from 1 to 2.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.