0

I have transmission-daemon/transmission-remote working on two machines, but on this third one (Ubuntu 18.04, transmission-daemon v.2.92), I am having trouble. Invoking transmission-daemon from the command line (not using systemctl), I keep getting a 404 response:

$ transmission-remote -l
Unexpected response: <h1>404: Not 
Found</h1>/transmission/rpc/Xe93UxLdqzChhkFNRcuAZbUV4sd9mjGMqS

I get the same response with any of the three: transmission-remote 127.0.0.1:9091/transmission/{rpc,rpcweb,web}/ -l

If I use a terminal browser (I don't have a gui interface with this computer), http://localhost:9091/transmission/rpc/ gives me a "409 conflict"

Your request had an invalid session-id header.

To fix this, follow these steps: 1. When reading a response, get its X-Transmission-Session-Id header and remember it 2. Add the updated header to your outgoing requests 3. When you get this 409 error message, resend your request with the updated header

This requirement has been added to help prevent CSRF attacks.

X-Transmission-Session-Id: 5z1zobwQxP90MmXe93UxLdqzChhkFNRcuAZbUV4sd9mjGMqS

On the other hand, if I go to http://localhost:9091/transmission/, I get a redirect to http://localhost:9091/transmission/rpcweb/, a comment about "Bad HTML!!", and then a page full of options. If I go to that page directly, or http://localhost:9091/transmission/web/, I get the similar page of options. (Note the "/" at the end of these. You get different results if it's not there!)

My .config/transmission-daemon/settings.json is that same on all these machines, where I am happily using stig, though as I say, transmission-remote works fine. I have also added a "/" to the end of my transmission/rpc/ setting, as mentioned in another answer. That doesn't help.

Furthermore, if I instead use systemd, systemctl start transmission-daemon, then trying to get in through the web interface asks me for credentials (username/password), even though they are not set in settings.json. When I shut down the daemon and check the settings file, I find that systemd has changed the file, adding a password but no uname, and no switch turning on authentication. If I turn that on myself, adding a reasonable uname/pwd, and restart the daemon with systemctl, it asks for the uname/pwd, but refuses to log me on. Systemd runs that daemon under the user debian-transmission. It doesn't help if I try to run the browser as that user (sudo -u debian-transmission lynx ...)

Does anyone have any insight as to what might be going on??

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.