1

I have an internet-less ubuntu server (amd64) which is accessed via ssh. To install a package i installed "libc6-udeb_2.13-38+deb7u10_amd64.udeb" which messed up everything. Now i get this error

sudo: /lib/libc.so.6: version `GLIBC_2.14' not found 

on very command that i give. No new ssh connections can be created, only the one that i am working on is live. There is no way i can "apt-get update" as there is no Internet. I cannot manually install the packages as i wont be able to copy them to the server.

This is a very valuable machine and i cannot tweak the OS. I have looked up this problem but the solutions require internet access. I cannot install using flash drive either. I am stuck bad. It is not running any command either.

Can anyone please help?

7
  • yes this one packages.debian.org/wheezy/libc6-udeb – RNA Aug 25 '18 at 8:29
  • No, it still gives the same error "cat: /lib/libc.so.6: version `GLIBC_2.14' not found (required by cat)" – RNA Aug 25 '18 at 8:40
  • No, it does not run any command. I tried purging. – RNA Aug 25 '18 at 8:41
  • I ran into a similar problem with libc.so.6 and GLIBC_2.27. I spent hours trying to fix it. In the end I just created a new partition and installed Ubuntu on it. Then I mounted the old partition and manually copied over data directories I needed. I feel your pain... – WinEunuuchs2Unix Aug 26 '18 at 15:45
  • @WinEunuuchs2Unix this is what i am thinking as well. However, this would not export all the valuable installations and the setup that was done on this server. Is there any way in the world that i could reverse this mess? – RNA Aug 27 '18 at 12:20
0

Screenshot from my Debian system

Not sure how to solve this issue. I browsed the net and took a screenshot from my debian system. Maybe the following link could help you start solving your problem somehow. Sorry, https://askubuntu.com/a/64963/196781

1
  • That might actually work. But the issue is that none of my commands are being executed except basic cd etc – RNA Aug 25 '18 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.