0

I'm trying to get a dual boot running on my custom desktop PC and I'm struggling with getting the OS to work. Ubuntu will successfully boot from USB, but afterwards I cannot use the keyboard or mouse to give input.

I can boot into recovery mode and have Ubuntu respond to the keyboard. I can also use the keyboard & mouse perfectly from Windows 10. I've also tried a mouse that I know works with Linux to no avail. Multiple flavors and pendrives do not change the behavior.

What sort of settings can I change from recovery mode to make the peripherals work? Is there another approach I should be taking?

Thanks in advance

  • I'm assuming as this is a custom desktop, it's a uefi system. So I suggest you look in to what you need to do before you install ubuntu, such as entering bios and turning off secure boot, turning off fastboot, turning off csm. Also check the various grub kernel boot options to handle problematic hardware. As you mentioned dual boot, you probably also need to turn off fastboot in windows as well. – nobody special Aug 25 '18 at 3:12
  • I disabled safe and fast boot. This changed nothing, mouse & keyboard still do not work. When I tried to disable csm, Windows would not boot. Interestingly enough, when I check the desk for defects, the check finds an error in one file, but doesn't tell me which. The keyboard stops working at this point and I can't press any key to reboot. – dropTableUsers Aug 25 '18 at 21:29
  • I'm surprised windows stopped booting. What version of windows are you running? I guess you could need it for an older gfx or something. You can have a root around in your bios to see if there are any settings for keyboard. You can try some kernel boot params like acpi=noirq or acpi=off or noapic or pci=noaer or pci=noacpi maybe reset_devices. Any of those boot params may help, but try them one at a time. Use them by highlighting ubuntu in the grub boot menu, press e, locate the line starting with linux and add them to the end of the line. Press <ctrl>+X to boot. – nobody special Aug 25 '18 at 22:49
  • I tried all the commands and they did not work. I did find the source of the problem nonetheless. Once I connected the peripherals to a different USB port they started to work again. I have no idea the rhyme or reason behind this. However I do know that now I'm in the market for a new motherboard. Thanks for the help. – dropTableUsers Aug 26 '18 at 0:56
  • No prob, glad you solved the problem. It sounds like you have something dodgy with the usb port, so a new mobo could well be needed. But before you do that, is the faulty usb port on the mobo back plane or the front of the case? If it is the front case port, then the cable that connects to the mobo header could be loose or even just be faulty, if so it would just need reconnecting or replacing. Check your bios settings as well, if you have been adjusting other settings in the bios recently, you might have disabled the usb port while without realizing it. – nobody special Aug 26 '18 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.