I have an Ralink wifi card installed. The driver shipped with ubuntu 11.10 does not appear to run my card.

On the ralink website there is a source download for compiling the driver but being new to linux i dont understand exactly what i am supposed to do, I understand that i need to use make to compile the driver.

What i dont understand is the files listed in the readme for the download. if i post the code from the two files it states to edit (they have stated its distributable) can somebody please take a look at it. or if you want to download the driver source and take a look yourself this is the link to it

http://www.ralinktech.com/en/04_support/license.php?sn=5019 (download form)

http://www.ralinktech.com/en/04_support/support.php?sn=501 (downloads list page) RT3062PCI/mPCI/CB/PCIe(RT3060/RT3062/RT3562/RT3592) specific driver

As you can see they have not made it simple there are several driver versions that can be compiles from this one package, and this is whats causing me the problems i know which version i need to use, 3062 but i dont know what to edit in the two files to compile that driver.

If you want me to post the code instead of downloading it reply and i will get back to you later this evening when i am back home.

  • This is still unresolved, the device is still displaying the old driver as being the one in use even though i have blacklisted that driver, the only difference is now that wlan0 does not create at all, the device pci card isnt firing up at all, I have tried changing the chipset to 3062, no difference from that to the 3562 it just doesnt want to play at all. – chris Feb 27 '12 at 6:37
  • ok so i have removed the blacklist for the rt2800pci driver, this driver is the build in driver, the device is coming up but not online, i cant fathom this out it doesnt make any sense to me what so ever, if the connection manager can now see the wlan0 device again, why is it that it cant use it. – chris Feb 27 '12 at 6:50

Note, i have not gotten this working for the kernel but does for the

Okay I have come back to this with a fresh set of eyes and no hangover. My Card is now working.

A quick recap follows to assist anybody who may need help with this card/chipset.

Download your driver from the ralink Website
If your downloads default to "Downloads" directory you should be able to just copy and paste the commands into the terminal unless the driver version you download has been updated in which case edits will need to be made.

This Guide is assuming a chipset of 3062 but will work just the same for any of the drivers in the source download.

Terminal (ctrl + alt + T)
tar -C Driver -zxvf ~/Downloads/DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217.tgz

cd Driver/DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217

gksu gedit Makefile may get password prompt
Check that the driver version is the version or your chipset eg: 3062. edit, save and close gedit.

gksu gedit os/linux/config.mk
Check the supplicant entries are set correctly, should read y for each. there are two of them. edit save and close gedit.

sudo make Make the driver

sudo make install Install the new driver

mkdir /etc/Wireless/RT2860STA If not existing

sudo cp RT2860STA.dat /etc/Wireless/RT2860STA/RT2860STA.dat copy the dat file over.

sudo modprobe rt3062sta start the module

sudo lspci -v check module is being used by card.

Blacklist Built in Mod
gksu gedit /etc/modprobe.d/blacklist.conf

At end of the file add, save and exit.
// Default kernel module does not work
blacklist rt2800pci

Make Sure the module is known.
gksudo gedit /etc/initramfs-tools/modules

Edit (add module name only), save and Exit.

This should be you finished here. If the driver is being used but the device has not come up then reboot the system. Good luck.

| improve this answer | |

You are making things too difficult for yourself. You only need to follow the instructions in the readme to set up the SUPPLICANT parameters (there are two of them that need to be set to "Y"). Then run the "make" and "make install". You need to blacklist the rt2800pci stuff and add rt3562sta to your modules list. These are in /etc/modprobe.d/blacklist.conf and /etc/initramfs-tools/modules, respectively.

You may need to copy RTA2860STA.dat to /etc/Wireless/RT2860STA/

Then run "modprobe rt3562sta" and your wireless should come up.

To verify, run "sudo lspci -v". It should show "Module in use: rt2860".

I know it is weird that your chip is 3062, the driver you install is rt3562sta, and the kernel module is rt2860, but I have the same card and that's the way it is. Good luck!

| improve this answer | |
  • sorry for the delay in replying i have had a busy weekend, i still have not solved this but i have just ui driver update started downloading so i am hopeful that will help, i have tried what you said but no joy as yet. if this update fails i think i may have to contact ralink and ask them for some help with it. – chris Feb 26 '12 at 14:19
  • Also i blacklisted the 2800 driver but it still appears that its being picked up according to the pci device info, I added "blacklist rt2800pci" to blacklist.conf and "rt3562sta" to the modules file – chris Feb 26 '12 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.