2

I am attempting to edit Gnome-Terminal profiles from the command line using gsettings. In order to use gsettings I need to know the keys and values contained in each profile. My problem is that dconf-editor does not display these. I can use dconf-editor to view everything down to /org/gnome/terminal/legacy/profiles/default. This displays the UUID for the profile but does not display any of the key/value pairs in the profile. How can I access this information so I can edit a profile using gsettings?

2

In fact dconf-editor does show the keys and values of each profile, in the subdirectories of /org/gnome/terminal/legacy/profiles:/. Their names are UUID's, with a colon prefix. But the default profile only shows up if it's been modified.

screenshot of dconf-editor

If you still want to use the command line, dconf seems like a better choice, since as far as I can tell, gsettings doesn't have access to the individual profile settings, only the default settings for new profiles (not the settings of the default profile). Though on the other hand, dconf doesn't seem to have access to the default settings.

dconf

Get profiles:

dconf list /org/gnome/terminal/legacy/profiles:/

Get profiles with their names (from Sergiy's answer here):

dconf dump /org/gnome/terminal/legacy/profiles:/ | awk '/\[:/||/visible-name=/'

List all settings:

dconf dump /org/gnome/terminal/legacy/profiles:/

gsettings

Get profiles:

gsettings get org.gnome.Terminal.Legacy.ProfileList list

Get default profile:

gsettings get org.gnome.Terminal.Legacy.ProfileList default

Get settings (I think these are the default settings for new profiles):

gsettings list-recursively org.gnome.Terminal.Legacy.Profile:/
6
  • On my system, when I select the default profile in dconf-editor I only get a screen which permits me to select whether to use the default UUID or provide a custom UUID. I do not get a screen listing the keys and values for the profile as I do farther up in the hierarchy. Do you mean that there is a way to get such a screen? – Jonathan Aug 24 '18 at 18:09
  • 1
    @Jonathan You're selecting the setting for which profile is default not the actual default profile itself. Go up a level, look up, and you'll see the profile directories there. I'll add a screenshot. – wjandrea Aug 24 '18 at 18:11
  • You are right. I simply did not realize that the top line was active. – Jonathan Aug 24 '18 at 18:13
  • @Jonathan Actually I just tried some things and noticed if you haven't edited the default profile, it doesn't show its subdirectory. That might be part of the confusion. – wjandrea Aug 24 '18 at 18:18
  • Actually I had edited it before trying as I had encountered this proviso. – Jonathan Aug 24 '18 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.