6

My Ubuntu 18.04 updated last night and now when I boot the system up it shows this message:

aufs aufs_fill_super:912:mount[1089]: no arg
overlayfs: missing 'lowerdir'

Any clues?

  • aufs indicates that it is a persistent live system of Ubuntu 16.04 LTS. Or a severe bug. The corresponding device for the root file system is cow in a persistent live system of 18.04 LTS. (And there should be none of those and no overlayfs in an installed system.) – sudodus Aug 24 '18 at 17:21
  • @sudodus thanks for answering. I'm using a fresh 3 month Ubuntu 18.04 so I don't know what is happening.. – Gabriel Panza Aug 24 '18 at 17:40
  • Is it a persistent live system or an installed system? (If you don't know, what a persistent live system is, it is an installed system.) – sudodus Aug 24 '18 at 17:41
  • If you have more than one kernel in your system, please try to boot into an older one and tell us the result. – sudodus Aug 24 '18 at 17:59
  • I have this issue after upgrading to 18.04. The GUI doesn't load, but I get a login prompt. I am on kernel 4.15.33 and while trying 4.15.32 I noticed it said giving up waiting for suspend/resume devices before going to the login screen. – Eric Fossum Sep 2 '18 at 1:29
2

I had the same issue. I booted in recovery mode and open the shell prompt. Then discovered that no free space left in my device (with df command). So I cleaned up space (menu in recovery mode has this item). And after that, the issue was resolved

0

Problem

I guess it was after an update when I have had the same issue. In my case it was related to the Xorg / Nvidia graphics card driver, I guess. How this is connected to the corresponding error message, still is a mystery to me.

Past the passphrase-prompt for the decryption of the drive, I got the same error message.

aufs aufs_fill_super:912:mount[1089]: no arg
overlayfs: missing 'lowerdir'

Booting in verbose mode, I noticed an error somewhat like this where it hang:

Failed to connect to lvmetad.
Falling back to device scanning.
/dev/mapper/ubuntu--vg--root: clean, 500699/15081472 files, 9150222/60315648 blocks

I tried the following without success:

  • Freeing diskspace
  • rebuilding / updating initramfs and grub
  • /etc/lvm/lvm.conf: change use_lvmetad=1 to use_lvmetad=0

Solution:

Booting / login via recovery-mode was still possible so I could make the following changes. If the usual logging-in had not been possible I would have had to make the changes via chroot:

  1. I had to change the driver: X.Org-X-Server to the proprietary NVIDIA driver
  2. Not sure if that was necessary: sudo apt-get install --reinstall linux-image-4.15.0-54-generic (adjust to current version)

res: Failed to connect to lvmetad - Stuck on boot

Info / side-effects:

The driver swap also solved and other odd issue (gnome-shell high cpu) that I was experiencing: My gnome-shell-process constantly was using about 30-50% CPU(!) now it is on 1-2%.

Lastly, the constantly noisy fan:

There may be a way to manually change the fan-speed (http://www.upubuntu.com/2015/05/how-to-controladjust-gpu-fan-speed-for.html) or you can simply use the integrated GPU.

  • NVIDIA X Server Settings -> PRIME Profiles -> select Intel. (You have to logout and login again for this to take effect).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.