I'm try to get a landscape server up to have a look at how it works. I've followed the install from https://landscape.canonical.com/set-up-on-prem

sudo add-apt-repository ppa:landscape/18.03 sudo apt update sudo apt install landscape-server-quickstart

At the end of the install I get:

    Created symlink /etc/systemd/system/multi-user.target.wants/landscape-package-search.service -> /lib/systemd/system/landscape-package-search.service.
Job for landscape-package-search.service failed because the control process exited with error code.
See "systemctl status landscape-package-search.service" and "journalctl -xe" for details.
Setting up landscape-server-quickstart (18.03-0ubuntu18.04.1) ...
Device "eth0" does not exist.
Skipping self-signed certificate generation.
ERROR: need a X509 certificate file in /etc/ssl/certs/landscape_server.pem and a
       key file in /etc/ssl/private/landscape_server.key.
Please fix this and reconfigure the package when done.
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for systemd (237-3ubuntu10.3) ...
Processing triggers for ureadahead (0.100.0-20) ...
Processing triggers for rsyslog (8.32.0-1ubuntu4) ...
Processing triggers for ufw (0.35-5) ...

I'm not sure on where the get the x509 certificate or key file that is mentions in the error.

The message 'Device "eth0" does not exist' show because this is in a VM and has the label for the nic as ens160.

Anyone come across this or have any ideas where to start looking?

Thanks

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.