I have a dual boot system with Ubuntu 17.10 and Windows 10 that's been working perfectly. Yesterday, I updated my system from Ubuntu 17.10 to Ubuntu 18.04. The process went ok and I had no problems booting Ubuntu 18.04 after the update. However, I noticed that I couldn't adjust the screen brightness either from the adjustment menu or the keyboard. In order to fix this, I edited /etc/default/grub and changed 'quiet splash' for 'quiet splash acpi_backlight=vendor' with the hope that this will fix the issue. I updated grub and reboot my system, but it booted into a purple screen. Neither the Ubuntu logo or the login screen appear.

I tried to edit my boot options from the grub menu, going back to the original 'quiet splash', 'nomodeset', etc. but none of these options seem to work. It continues to boot into a purple screen, and I am also not able to open a text session with Ctrl+Alt+Fx. I'm desperate because I don't know what else I can do to fix this, since the system was working perfectly before I made that modification. My video card is a Nvidia and I had the proprietary drivers installed in Ubuntu 17.10.

*Edit: I have tried accessing the system through Linux 4.15 safe mode, but I get the error 'Kernel panic not syncing vfs unable to mount root fs on unknow block' *Edit 2: Finally I could enter safe mode with the Linux kernel 4.13. I edited /etc/default/grub and set it to the original 'quiet splash', but the system still boots into the purple screen. I am beginning to suspect this has more to do with the update itself than with my grub edition.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.