upgrading 17.10 to 18.04 I stupidly set a keyboard shortcut for switching input languages to Left Ctrl, and it messed up copy paste Ctrl+C, Ctrl+V, now they work with Right Ctrl, which is highly inconvenient.

I tried to fix it in keyboard settings, but I can't see either of those 3 positions (neither 'alternative switch to next source' - changes input language, nor copy or paste to clipboard) on the list so can't change it there.

I suppose I would need it to fix it manually, but I don't know what command to type in.

as on the screen below 2nd position says command.

enter image description here

So do you know how could I change it back? Do I need to add it manually if it's not on the list of shortcuts in settings->keyboard? If yes what command to use?

Would be very glad for help.

  • Even if the question is not exactly the same as yours, I'd guess that this answer applies to your problem too. – Gunnar Hjalmarsson Aug 24 at 12:12
  • thanks so much, I found an answer there. I installed gnome tweaks and went to Key and Mouse -> Additional Settings -> Switching to next source -> here I unclicked the box with my setting – Hubert Śmieciuch Aug 24 at 12:57
  • Right, that's the GUI way. Great that you solved the issue! – Gunnar Hjalmarsson Aug 24 at 13:32
  1. Install gnome tweaks "sudo apt-get install gnome-tweaks".
  2. Open gnome-tweaks.
  3. Go to "Keyboard and Mouse" and then click on "Additional Layout Options (Image)
  4. Click on "Switching to another layout" and deselect "Left Ctrl". (Image)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.