I updated my desktop Pavillion a623.sc from Ubuntu 16.04 LTS to 18.04 LTS. After downloading I could not re-boot nor boot the desktop. The booting process starts, Ubuntu logo comes up, but the password page does not follow, instead only empy lila page stays on the screen.

Now I can make booting only manually via ''Ubuntu with Linux 4.15.0-33-generic (recovery mode)'. There I updated also GNU GRUB version 2.02, but it did not help with the booting problem.

((Earlier I made similar online update to my other pc, HP 6930p laptop, and all works OK without any booting problems.))


Ubuntu 18.04 LTS switched to the Gnome Display Manager (GDM), that, currently, does not support the AMD Display Driver(AMDGPU).

As a temporary fix, you can switch back to LightDM (the one used in Ubuntu 16.04 LTS) by following the instructions in this post: How to change from GDM to LightDM?. When prompted, make sure you choose lightdm.

After you restart the computer, you should get a the Login screen.

  • I just tried this solution, but got the following result: '' dpkg: error processing package lightdm (--configure): package lightdm is already installed and its' settings are made. Too many mistakes took place in handling: lightdm '' (My translation from Finnish to English, KP), Brdgs, Kauko Peltonen – Kapel Aug 24 '18 at 14:02

Solution #1: Chronologically, I tried this afte Solution #2 - in which I uninstalled amdgpu, but kept to using gdm3 and gnome.

Then I downlaoded amdgpu 18.30 driver and installed it. It needed two reboots, but now it seems to be working fine.

Solution #2: Uninstall amdgpu driver. https://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx After restart, I was presented with gdm3 and could successfully log into my desktop.

The solution with installing lightdm got me only as far as seeing lightdm, but gnome still couldn't load and crashed.

+1: I only accepted the online update. I was already using 18.04 from a fresh start.

I could start the recovery mode. Going to full mode from recovery mode gives access to some extra info. From the logs I see that gdm starts but then hangs:

Started Session c4 of user Gdm.
Starting User Manager for UID 120.
Started User Manager for UID 120.
Starting Manage, Install and Generate Color Profiles...

« and there it hangs, the screen is flashing from console to graphical purple and back then it all stops.

Updating gnome-core by hand didn't help.

Not sure it is relevant, but in the journalctl -k:

[drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting

jourlnalctl -b:

[drm:radeon_init [radeon]] *ERROR* No UMS support...

There is "blacklist radeon" in my /etc/modprobe.d/blacklist.conf.

The solution above got me to a login screen, but I cannot actually log in (gnome crashes) and ctrl-alf-f* to another console crashes too, not even letting me to a shell.

  • Does this same difficult problem with booting take place also after installing Ubuntu 18.04 LTS from the disk over (or instead of) the the Ubuntu 18.04 LTS downloaded online? Brgds Kauko Peltonen – Kapel Aug 24 '18 at 13:54
  • I don't know, it might be worth a try. But you wrote that you managed to fix the issue for yourself with lightdm, didn't you? For me, reinstalling the video card driver worked. But as far as I see, your HP laptop does not have AMD GPU, so the source of the problem might be different after all than it was for me. – mrnagydavid Aug 29 '18 at 6:40

I received from Ubuntu Finland discussion group members the following instruction, which solved the booting problem in my desktop:

First, run the command:

sudo dpkg-reconfigure lightdm

Then select LightDM instead of GDM from there. Finally, I rebooted twice. The result was positive. Now the boot process worked OK on this desktop.

  • Sorry for my misprint, instead of GLightDM there should be LightDM. – Kapel Aug 25 '18 at 9:33
  • Yu can always edit your own posts by clicking the light grey word "edit" below it to fix any errors. – jknappen - Reinstate Monica Aug 27 '18 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.