9

I just installed Oibaf's graphics driver, on my laptop, and also Lutris (with Wine and all that) beacuse I want to play games like Diablo 3.

Everything worked fine, I also installed vulkan, and Wine + Gallium Nine The output of lshw -c video is :

  *-display                 
   description: VGA compatible controller
   product: HD Graphics 5500
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 09
   width: 64 bits
   clock: 33MHz
   capabilities: msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:45 memory:d3000000-d3ffffff memory:c0000000-cfffffff ioport:7000(size=64) memory:c0000-dffff
 *-display
   description: Display controller
   product: Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430]
   vendor: Advanced Micro Devices, Inc. [AMD/ATI]
   physical id: 0
   bus info: pci@0000:0d:00.0
   version: 83
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi bus_master cap_list rom
   configuration: driver=radeon latency=0
   resources: irq:46 memory:b0000000-bfffffff memory:d5000000-d503ffff ioport:4000(size=256) memory:d5040000-d505ffff

My video card is AMD R5 M430, and the laptop is HP 250 G5

Also here is the output of lspci -k | grep -EA3 'VGA|Display|3D'

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
        Subsystem: Hewlett-Packard Company HD Graphics 5500
        Kernel driver in use: i915
        Kernel modules: i915
--
0d:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 M520] (rev 83)
        Subsystem: Hewlett-Packard Company Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / R7 M520]
        Kernel driver in use: radeon
        Kernel modules: radeon, amdgpu
  • Have you tried to disable your on-board graphics card from BIOS? – Alex Aug 26 '18 at 14:10
  • @Alex I'm afraid that I cannot do it on my HP 250 G5, just checked it. – sticsk Aug 26 '18 at 14:13
  • @sticsk Were you able to get this working i.e. switch from Intel to AMD ? – gansub May 31 at 3:28
5

You can find many answers to your question here in Ask Ubuntu:

You should review all of these links.

Additionally you will find many helpful links from other sources:

All the links are too long to summarize in this answer.


Rather than using lspci -nn | grep VGA which will only show your Intel GPU and not your AMD GPU you should try an expanded search using something like this:

$ lspci -k | grep -EA3 'VGA|Display|3D'
00:02.0 VGA compatible controller: Intel Corporation Skylake Integrated Graphics (rev 06)
    DeviceName:  Onboard IGD
    Subsystem: Dell Skylake Integrated Graphics
    Kernel driver in use: i915
--
01:00.0 3D controller: NVIDIA Corporation GM204M [GeForce GTX 970M] (rev a1)
    Subsystem: Dell GM204M [GeForce GTX 970M]
    Kernel driver in use: nvidia
    Kernel modules: nvidiafb, nouveau, nvidia_384_drm, nvidia_384
  • 1
    The one from August 2018 is mine... and I already reviewed the first and the 3rd one and they aren't working. Switcheroo isn't working either it won't change to the discreet, I made it work it on 16.04 but it still shows that I'm using the Intel one from Settings for example. And AMDGPU driver isn't available for my AMD R5 M430, that's why I installed Oibaf's driver. I'll check the Prime one though – sticsk Aug 26 '18 at 16:22
  • @sticsk Sorry I didn't pick up on the fact you were one of the authors in the links. You've obviously been doing your homework and trying all the common solutions. Let me know if this answer is unhelpful to you or others and I will delete it. Thank you. – WinEunuuchs2Unix Aug 26 '18 at 16:26
  • I updated the lspci command ; EDIT : I will also check the PRIME from Arch and let you know if something's going on. – sticsk Aug 26 '18 at 16:31
  • The edit to lspci makes it more informative. I just found this you might be interested in: linuxconfig.org/… – WinEunuuchs2Unix Aug 26 '18 at 16:38
  • 2
    I would use Olbaf's as a last resort because that is what we call "Bleeding Edge" technology. I try to stick to the mainstream technology as much as possible. Another piece of advice when dealing with multiple drivers you have to be extract thorough in ensuring the previous one is fully removed before installing a new one. This is a common problem in the nVidia graphics world in Linux. – WinEunuuchs2Unix Aug 26 '18 at 16:57
1

I have been plowing the internet for days over this issue. Had similar setup and problems. I chanced upon here about using DRI_PRIME=1 before any commands to use your dedicated GPU. So I tried

export $DRI_PRIME=1

and this worked. So I added a line it in /etc/environment, DRI_PRIME=1 , rebooted and now System Details shows my AMD card as default.

Caveat: I think this disables the Integrated Graphics and changes your system to just make use your dedicated GPU only

  • Damn man I actually forgot about this question, idk if this will help someone, if it does let me know to mark it as solved. I switched Ubuntu for months ahahahah – sticsk Jul 12 at 8:50
  • Hahahaha I almost gave up to change Ubuntu version too – roarnald Jul 12 at 9:00
  • It was good when I started but now I improved and I switched to another distro – sticsk Jul 12 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.