12

This is a small nuisance I've had in Ubuntu forever. When I set my computer to login automatically, Network Manager asks me for my keyring password every time it boots and it refuses to connect to the Internet until I enter it. Is there a reason for that?

Also, other network managers such as Connman don't have this problem, and I have noticed the latter also has an application indicator while NM-applet runs in the Notification Area. Are there plans to migrate to Connman, or to adapt NM-applet for Natty?

  • Are you sure that it is the root password? What does the dialogbox say/look like? It seems much more likely that it is your user password used to decrypt saved passwords in Gnome Keyring. – LassePoulsen Nov 1 '10 at 9:16
14

There is an option in Network manager not to use password. If you edit the connection, at the bottom of the page there is a box "available to all users" if you tick this it will not require a password.

To edit right click the icon, select edit Connections, select wireless,select your connection and click edit.

screenshot

  • 1
    So THAT's what that checkbox was for! I feel dumb now, I've suffered this nuisance for years and I could have fixed it in a minute! – Bou Nov 1 '10 at 13:05
  • Important to note that anyone with root/admin access on your PC will now be able to edit that network manager applet and see your WEP/WPA key. Probably fine, but if you're using PEAP authenticated connections, that key is your network password - huge security risk. Crazy that nm-applet shows you your password at all. I have the same gripe about Seahorse. – Scaine Nov 29 '10 at 18:51
  • actually, it should have a VERY different name. "available for all users" doesn't mean at all that your password is gonna be saved (and that's a very common use of this checkbox). Another thing is that for you to check this box, you need to go to the last tab and write down your password and only after this the box is gonna be clickable (also zero usability). – Pabluez Dec 30 '11 at 12:15
  • @Scaine: You expect to keep root from discovering your wifi passwords? – SamB May 11 '15 at 21:29
  • @SamB, Of course not. I'm merely pointing out that anyone with root access to that box will see your Active Directory password if you're using PEAP. – Scaine May 19 '15 at 20:11
6

NM does not ask for your root password! It asks for your keyring password.
Your keyring saves passwords encrypted, so no one can steal them. That is why you need to enter your keyring password, so Ubuntu can decrypt your passwords to use them (eg. to get your WLAN-Password).

You can check the content of your keyring in Menu -> System -> Preferences -> Passwords and Encryption Keys. Here you will find all your passwords in cleartext, after you unlocked your keyring (rightklick an element -> properties -> password -> show password).

To change your keyring password, rightklick the line Password: login and choose Change Password

Choosing no password will make keyring never ask for any password again, but still save them (unencrypted! So this should not be your first choice on a Notebook).

  • Thank you guys for your answers. I don't really care about my network passwords. For the time being I will remove my keyring password since no one has physical access to my laptop, but that's not an option I'm comfortable with, so I guess I'll file a bug against Network Manager, see if it's possible to have an option not to use the keyring. – Bou Nov 1 '10 at 10:05
  • 1
    I believe that syncing your keyring password with your login password will also stop it asking you for it. Just set it using the same method described above. – Nerdfest Nov 1 '10 at 11:13
  • The problem is, he uses autologin, that's why syncing the passwords is not an option – sBlatt Nov 1 '10 at 14:10
  • @Bou I wouldn't worry about a bug report, having a blank password would be tantamount to not using it in the first place, if you feel uncomfortable with one option, presumably you would with the other – johnc Nov 9 '10 at 23:49
1

The reason why NetworkManager asks for your password is that it wants to keep your passwords in a safe place (an encrypted keyring), while ConnMan doesn't care about that...

If you don't care about security, you can remove the password from the GNOME keyring, or use ConnMan instead...

And migrating to ConnMan as the default in Ubuntu is currently no option, as it only support Ethernet and WiFi, but no modems (PSTN, ISDN, DSL, 3G), Bluetooth, VPN, etc.

0

As said above it is primarily a security feature. It disallows unauthorized users to access/modify data on your PC.

0

For WPA-Enterprise connections using a username/password, the password is usually stored in the user keyring, even if the "available to all users" checkbox is ticked.

The only way I have found to prevent that NetworkManager asks for my password is by manually editing the connection settings:

  1. Edit the network connection, making sure the "available to all users" checkbox is enabled. Save it.

  2. Open a terminal and change directory: cd /etc/NetworkManager/system-connections. Each file in that directory represents one of the connections saved to "all users" by NetworkManager.

  3. Use sudo grep flags * to list all the files that use password flags. You will see the file name that represents your WPA Enterprise wifi connection. Let's call that file myconnection.

  4. Edit the file sudo nano myconnection

  5. Go to the section [802-1x] in the file, remove the password-flags and add a line password=mypassword.

  6. Save the file

On the next reboot NetworkManager should have the password already, so it should not need to unlock the keyring to connect to it.

Note that this approach stores your password in a plain text file. Although the text file is only readable by root, NetworkManager is able to read it, and any user can see the password as well going to the "edit connection" settings in NetworkManager. This solution may be practical to users who use a paswordless-login on a computer that is only used by them.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.