4

I just updated to 18.04 from 16.04 and to 16.04 to 14.04 before that.

Anyway the 18.04 failed with an error saying something like gnome not installed and desktop depends on gnome. And it said it was going to recover, however it did nothing. After some time I restarted and the system. It came up with the desktop background but nothing else.

With Ctrl-Alt-F1 I am trying any commands I found without success.

Trying to install gnome I get missing dependencies. When trying to install gnome-shell and have a dependency for libmutter-2-0.

I installed libmutter-2-0 but gnome-shell still reports it as a missing dependency.

I also don't have gdm3 or seemingly any other parts of gnome.

I have no idea what I am doing, I have been searching and running commands for installing anything I can find, but so far no success.

I would like to get some gui working or go back to 16.04 if possible.

Edit 1 After N0rbert's advice:

sudo apt-get update
sudo apt-get install ubuntu-desktop

Did something in the sense that I can see my a desktop, but I only see a login button the the account, which instantly fails even before I have a chance to enter my password. Here are some screenshots: login failed after click

Crash screen In previous version I had it not require a password to login so I am surprised it is asking for one. Is it possible I just need to reset the password or authentication system?

  • 1
    Please add error messages to the question. Something like output of sudo apt-get update, sudo apt-get install ubuntu-desktop. – N0rbert Aug 23 '18 at 16:22
  • Thanks, after sudo apt-get update now sudo apt-get install ubuntu-desktopactually does something other than saying that there are missing dependencies. Not a single post mentioned sudo apt-get update before the other commands. Should I try to restart now? – MichaelE Aug 23 '18 at 16:28
  • Theoretically sudo apt-get update are launched periodically on its own. But for predictable results it is recommended to run it before installation of something. See this official documentation. If package installation is finished then you can reboot. The APT (package manager) is essential part of Debian and Ubuntu OS. You should learn it before use :) – N0rbert Aug 23 '18 at 16:35
  • Of all the things I tried, sudo apt-get install gnome-core did a lot of stuff, but overall it did not help. Then with more searching for login issue I found dpkg-reconfigure lightdm then i picked lightdm instead of gdm3 and after a restart I got the new desktop? Any ideas of what happened and anything else I might need to fix? Thanks again. – MichaelE Aug 23 '18 at 17:57
  • 1
    Yes, everything seems to be working fine with lightdm. – MichaelE Aug 23 '18 at 18:43
1

The following list of actions solved the problem:

sudo apt-get update
sudo apt-get install ubuntu-desktop
sudo apt-get install gnome-core lightdm
sudo dpkg-reconfigure lightdm # select LightDM

then OP successfully logged in to the session.

  • 1
    Thank you, that is exactly it. Hopefully it saves someone else hours of troubleshooting. – MichaelE Aug 23 '18 at 19:15
1

It is very probably related to an online update that was rolled out yesterday by Ubuntu.

People who have been upgrading to 18.04 yesterday are experiencing it (I cannot boot normally after online update 23.8.2018 from 16.04 to 18.04)

People (like who) have been using 18.04 but applied the patch are experiencing it (Debian login screen after updating Ubuntu 18.04)

I had the same problem as you on the second screenshot. The GDM starts but somehow cannot finish loading. I also noticed errors with amdpro and radeon module loading in the kernel log.

  • The solution above got me to a login screen, but I cannot actually log in (gnome crashes) and ctrl-alf-f* to another console crashes too, not even letting me to a shell. – mrnagydavid Aug 24 '18 at 10:51
  • Just now, the new version of libmutter-2-0 is available. Hope installing ubuntu-desktop fixes my System now. – jknappen Aug 24 '18 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.