2

I just bought a brand new Clevo N850EL (in some regions can also branded as Prostar or Sager NP4850), with CPU i7-8750H, 32GB RAM.

Ubuntu 18.04.1 installs OK and appears to run fine (with me working, typing, installing and removing software), until it crashes after some random time (after 45min +/- 30min).

(It has both NVIDIA MX150 and Intel HD graphics. I believe I am running with Intel HD graphics under Ubuntu).

The crash is a complete freeze (mouse does not move, TCP/IP connections become frozen and break, Ctrl+Alt+Del does not respond, has to be rebooted by pressing the power button for 5 seconds).

There is no abnormal entry in /var/log/syslog or /var/log/kern.log before of after the freeze.

So, it is just a misterious crash "freeze", with no log/trace that I know of.

(Edit: 2018-08-25 I enabled SysRq, but network services are frozen too, so I cannot ssh remotely and ask for SysRq, and keyboard Alt+SysRq+command seems frozen too).

On the 1st day, it had apparently the same problem running the Windows 10 that came with this PC.

But the problem disappeared once I upgraded to Windows 10 1803 (with all cumulative patches that were prompted, and multiple reboots). Now its completely stable under Windows 10 1803.

Seems like a "new hardware" problem under Linux, that Windows has overcomed recently.

What should I do ? Should I try to use an upstream kernels with Ubuntu ? (Which one ?) (Is there any USB pen version of Ubuntu that I can run all day with a newer kernel just to see if the problem is from the kernel ? Should I go to launchpad and open an issue ?)

(I don't really want to work under Windows ... :-(

Edit: Kernel is 4.15.0-32-generic

# lspci
00:00.0 Host bridge: Intel Corporation Device 3ec4 (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Device a379 (rev 10)
00:14.0 USB controller: Intel Corporation Device a36d (rev 10)
00:14.2 RAM memory: Intel Corporation Device a36f (rev 10)
00:16.0 Communication controller: Intel Corporation Device a360 (rev 10)
00:17.0 SATA controller: Intel Corporation Device a353 (rev 10)
00:1d.0 PCI bridge: Intel Corporation Device a330 (rev f0)
00:1d.5 PCI bridge: Intel Corporation Device a335 (rev f0)
00:1d.6 PCI bridge: Intel Corporation Device a336 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Device a30d (rev 10)
00:1f.3 Audio device: Intel Corporation Device a348 (rev 10)
00:1f.4 SMBus: Intel Corporation Device a323 (rev 10)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device a324 (rev 10)
01:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)
02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd Device a808
03:00.0 Network controller: Intel Corporation Device 2526 (rev 29)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
04:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

Edit 2018-08-24: Upgraded to kernel 44.15.0-33-generic. The problem remains the same.

Booted in console mode (GRUB option systemd.unit=rescue.target), turned on network manager and WiFi from the command line as root (see https://help.ubuntu.com/community/NetworkManager ), and copied some files over the network for some hours.

The problem does not occur in console mode. I did not place much load on the system from console mode, but I managed to copy a few GB of files from network, and with an uptime of more than 8 hours, with a few services and processes running, I think I can assume that the same crash/freeze does not occur in console mode.

Installed the nvidia-driver-390 proprietary drivers, and switched to NVIDIA with the commands:

sudo ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
sudo prime-select nvidia
sudo reboot
nvidia-settings # just to check that it seems installed

The problem remains the same with nvidia-driver-390 proprietary drivers.

Swicthed back to intel, and blacklisted the noveau kernel driver:

sudo prime-select intel
sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nvidia-nouveau.conf"
sudo update-initramfs -u
sudo reboot

The problem remains the same with intel video drivers, with noveau disabled.

It did not recognized the WiFi adapter, but it seemed stable under GNOME desktop mode for a few hours (I let it run for 2h30m while copying some GB of files through wired Ethernet to disk). (Later attempts to go back to this Debian testing, showed that it crashed/freezed frequently also.)

But, filled with new hope, I decided to try an Upstream kernel ( see https://wiki.ubuntu.com/Kernel/MainlineBuilds )

First I tried kernel 4.17.19-generic amd64. Crash/freeze in the first 5 min of uptime. (And again... problem remains the same)..

Then I tryed kernel 4.18.5-generic amd64. It seemed to run OK for some hours (more than 2 hours) but then froze and rebooted. More tests on the next day, and the problem seems to remain (and always crashes on reboot). (I tryed to disable WiFi, and using only Wired Ethernet, but the problem eventually happens again. Side-note: I seem to loose Wired Ethernet by DHCP after a hot reboot).

(Side-note 2: Meanwhile I de-blacklisted the noveau driver as it was causing related timeout errors in /var/log/kern.log. The "sensors" utility reports 511ºC temperature on the 3D adaptor :-)

Edit 2018-08-26 kdump: I tryed to configure kdump (as in https://help.ubuntu.com/lts/serverguide/kernel-crash-dump.html ), but, when I test it in graphic mode, I get exactly the same problem described in kdump doesn't log crash (system freezes, no messages, no reboot, no crash dump under /var/crash/ ).

If I trigger a kernel crash in console mode with

echo c > /proc/sysrq-trigger

then I see the crash messages on the console, and they are partially recorded on /var/log/syslog on the next reboot. Still no crash dumps under /var/crash.

So I am a bit lost. What should I try ?

Edit 2018-08-27: There are no DRAM memory errors I can find (memtest86.com runned all night - 6 hours and 16 min), and found no errors.

UEFI boot is disabled.

I downloaded the Ubuntu 18.10 daily build at http://cdimage.ubuntu.com/daily-live/20180827/cosmic-desktop-amd64.iso and used it as a live USB pen for a few minutes, but crashed/froze as usual.

(PS: In the 18.10 GNOME control panel, I could not see which graphics card was in use. It crashed/froze when I asked for the "Information" item).

Is there anyway to use a limited VESA graphic mode ? (I've tried Force VESA driver in Ubuntu 16.10 without success).

Edit 2018-08-28: Adding the information requested by user abu_bua:

root@jpsl-N8xxEL:~# hwinfo --cpu | grep -Ei "model\:|Features\:|Config Status\:" -m 4
  Model: 6.158.10 "Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz"
  Features: fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,ht,tm,pbe,syscall,nx,pdpe1gb,rdtscp,lm,constant_tsc,art,arch_perfmon,pebs,bts,rep_good,nopl,xtopology,nonstop_tsc,cpuid,aperfmperf,tsc_known_freq,pni,pclmulqdq,dtes64,monitor,ds_cpl,vmx,est,tm2,ssse3,sdbg,fma,cx16,xtpr,pdcm,pcid,sse4_1,sse4_2,x2apic,movbe,popcnt,tsc_deadline_timer,aes,xsave,avx,f16c,rdrand,lahf_lm,abm,3dnowprefetch,cpuid_fault,epb,invpcid_single,pti,ssbd,ibrs,ibpb,stibp,tpr_shadow,vnmi,flexpriority,ept,vpid,fsgsbase,tsc_adjust,bmi1,avx2,smep,bmi2,erms,invpcid,mpx,rdseed,adx,smap,clflushopt,intel_pt,xsaveopt,xsavec,xgetbv1,xsaves,dtherm,ida,arat,pln,pts,hwp,hwp_notify,hwp_act_window,hwp_epp,flush_l1d
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Model: 6.158.10 "Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz"
root@jpsl-N8xxEL:~# lspci -knn | grep -i vga -A3
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e9b]
    Subsystem: CLEVO/KAPOK Computer Device [1558:8555]
    Kernel driver in use: i915
    Kernel modules: i915
  • You might be served with attempting a simple installation first by using Intel GPU and possibly Ubuntu 16.04. We don't see many Clevo users around these parts. Hopefully one exists in Ask Ubuntu and sees your question. I noticed this question the day it was first posted and now that you've just edited. Sorry for your bad luck. – WinEunuuchs2Unix Aug 26 '18 at 22:30
  • Thank you for the answer. Meanwhile, I've tryed launchpad to see if I can reach someone that knows the hardware issue... bugs.launchpad.net/ubuntu/+source/linux/+bug/1789214 – user1544553 Aug 27 '18 at 14:09
  • Add the output of hwinfo --cpu | grep -Ei "model\:|Features\:|Config Status\:" -m 4 to your post. sudo apt install hwinfo to install – abu_bua Aug 27 '18 at 22:10
  • Add the output of lspci -knn | grep -i vga -A3 – abu_bua Aug 27 '18 at 22:20
4

Try to use the kernel parameter: intel_idle.max_cstate=1

do these steps:

  • sudo nano /etc/default/grub
  • replace the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"
  • save it (CTRL+O)
  • sudo update-grub
  • sudo reboot

Confirm the maximum allowed CPU C-State with:

 cat /sys/module/intel_idle/parameters/max_cstate

More info on https://bugzilla.kernel.org/show_bug.cgi?id=109051


Short description ++

In order to save energy when the CPU is idle, the CPU can be commanded to enter a low-power mode. Each CPU has several power modes and they are collectively called C-states or C-modes..

The idea of these modes is to cut the clock signal and power from idle units inside the CPU. As many units you stop (by cutting the clock) as you reduce the voltage or even completely shut down to save energy. On the other hand, you have to take into account that more time is required for the CPU to “wake up” and be again 100% operational. These modes are known as C-states. They are usually starting in C0, which is the normal CPU operating mode, i.e., the CPU is 100% turned on. With increasing C number, the CPU sleep mode is deeper, i.e., more circuits and signals are turned off and more time the CPU will require to return to C0 mode, i.e., to wake-up. Each mode is also known by a name and several of them have sub-modes with different power saving – and thus wake-up time – levels.

c-states


++ from https://gist.github.com/wmealing/2dd2b543c4d3cff6cab7/

| improve this answer | |
  • This workaround seems to work fine! Uptime of 3h23m by now. Tomorrow I will make a full 8h test (1 work-day), and if Ok, I will mark this answer correct. Thank you. – user1544553 Aug 27 '18 at 20:48
  • I have voted this workaround as correct. After a period of 6h45min of flawless uptime, this workaround intel_idle.max_cstate=1 is surely working well. (I need to reboot now to change some settings :-) – user1544553 Aug 28 '18 at 14:39
  • 1
    Amazing this Intel bug is still with us after what two years? +1 – WinEunuuchs2Unix Aug 29 '18 at 12:43
  • It come again with Ubuntu 18.04. first i thought it's a graphic's card issue or an apic setting fault. – abu_bua Aug 29 '18 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.