14

I'm using a Raspberry Pi 3 with Ubuntu 18.04. At my company we have a DNS server and a couple of domains with ".local". I know technically this isn't correct and it should be ".lan" instead, because .local is reserved for multicast dns. But that's the way it is and it can't easily be changed. So on my windows machine I can ping and browse to those domain names without trouble. On my Ubuntu however I can not.

I can not use IPs because some domains are on the same machine and the IIS webserver sorts things out what goes where.

I have searched and it comes up quite often:

However changing /etc/nsswitch.conf doesn't do the trick for me. I tried

  • hosts: files mdns4_minimal [NOTFOUND=return] dns myhostname # default
  • hosts: files dns
  • hosts: files mdns4_minimal [NOTFOUND=continue] dns myhostname
  • hosts: files mdns4 [NOTFOUND=return] dns myhostname
  • hosts: files mdns4 [NOTFOUND=continue] dns myhostname
  • hosts: files dns mdsn4_minimal myhostname
  • hosts: dns
  • a few others

None of which worked. I tried rebooting after a change too. I tried to tell avahi that the domain-name=alocal in /etc/avahi/avahi-daemon.conf, didn't work after service restart, didn't work after reboot. After this not working, I tried disabling the avahi-daemon service entirely.

sudo systemctl disable avahi-daemon

After a reboot I tried a couple of permutations in /etc/nsswitch.conf again, with no effect.

with my current settings in hosts (files dns) I get this response:

dig login.name.local # not the actual name

; <<>> Dig 9.11.3-1ubuntu1.1-Ubuntu <<>> login.name.local
;; global options: +cmd
;; Got answer:
;; WARNING .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33538
;; flags: qr rd ra; QUERY: 1, ANSWER:0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;login.name.local. 0     IN     A

;; Query time: 2msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Thu Aug 23 10:51:50 CEST 2018
;; MSG SIZE  rcvd: 56

However when I instruct dig to query the server directly I get the correct answer:

dig @dnsIP login.name.local
; <<>> Dig 9.11.3-1ubuntu1.1-Ubuntu <<>> login.name.local
; (1 server found)
;; global options: +cmd
;; Got answer:
;; WARNING .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57866
;; flags: qr aa rd ra; QUERY: 1, ANSWER:1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;login.name.local. 0     IN     A

;; ANSWER SECTION:
login.name.local. 3600 IN    A        serverIP

;; Query time: 2msec
;; SERVER: dnsIP#53(dnsIP)
;; WHEN: Thu Aug 23 10:51:50 CEST 2018
;; MSG SIZE  rcvd: 56

This version of Ubuntu uses netplan with the network manager. The correct DNS IP is definitely in the list. (in fact it's the primary DNS.) Also the dnsIp is the same as serverIP, but that shouldn't be an issue.

Ping or connecting via browser and such don't work of course. None use the dns query.

I'm at a loss at what to do. Certainly we can't switch to a different domain name. I put the servername into /etc/hosts but that's just a temporary solution.

  • changing the resolv.conf as jeremfg suggested worked for me after chasing my tail around this for several hours. Tnx. – user3529828 Nov 30 '18 at 20:33
11

I faced a very similar issue (if not exactly the same) on Linux Mint 19 (Tara). I've managed to solve it by combining 3 different pieces of information. It seems to all be related to recent changes with systemd-resolved.

First, yes I've needed to configure /etc/nsswitch.conf as you did and would expect. As long as dns comes before mdns you should be good. I ended with simply:

hosts:          files dns myhostname

ref: https://unix.stackexchange.com/a/457172/271210

Prior to upgrading to this version of Mint, this is the only thing I needed to do. Now I also ended up making the below two other changes to get it working...


After that I've configured my search domain so systemd-resolved would work as I wanted. So I've edited the file /etc/systemd/resolved.conf, the Domains setting under the [resolve] section. In my case it ended up looking like:

[Resolve]
#DNS=
#FallbackDNS=
Domains=trilliant.local
#LLMNR=no
#MulticastDNS=no
#DNSSEC=no
#Cache=yes
#DNSStubListener=yes

ref: https://askubuntu.com/a/1031271/872881

I've also changed the avahi configuration to something else ("mdns" if I remember correctly, but it doesn't matter). It shouldn't be required however from my understanding. Just adding for completeness.


But none of it worked until I've called the following:

sudo ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf

ref: https://askubuntu.com/a/938703/872881

After calling this, everything started working perfectly and as expected!

So it's possible I didn't really need to change the /etc/systemd/resolved.conf file but I kept this change since it made sense and allows me to only type a machine's name, without the complete FQDN, for DNS resolution to work.

  • You could have just put the last line in the beginning and I guess you would get more upvotes by doing so. – HongboZhu Jun 24 at 12:12
  • @HongboZhu I would if I knew for a fact that's the only change required to get local domains working. I'm pretty sure you still have to prefer dns over mdns in the resolver configuration too. I assume your comment pertains to the domain configuration in the middle? If so, yes I suppose I could put this at the end as an optional change. But the other two pieces are required IMHO. – jeremfg Jun 25 at 15:04
  • 1
    On my new 18.04.2 install, just change the "hosts" ordering at nsswitch.conf works already. – Tomofumi Jul 11 at 7:34
13

The accepted answer did not resolve my issue. It was nothing to do with avahi - I did not have avahi service installed. I have my system set to get its ip AND its dns server settings from DHCP. However, the dhcp supplied DNS was not being checked for queries using .local

The real issue is that Ubuntu 18.4 has its resolv.conf sym-linked to a stub file that points to the localhost for name resolution. Localhost dns name resolution means that the system refuses to check the supplied DNS server for .local names, believing (incorrectly) that such names are invalid. This is the default setup of /etc/resolv.conf:

ls -la /etc/resolv.conf
lrwxrwxrwx 1 root root 39 Jan 22 13:26 /etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf

content of the stub file is (comments removed):

 cat /run/systemd/resolve/stub-resolv.conf
 .. removed comments..  
nameserver 127.0.0.53
    search reddog.microsoft.com

the 'real' resolve conf has the 'correct' dns setting (from dhcp):

cat /run/systemd/resolve/resolv.conf

..removed comments..
nameserver 10.168.200.250 # This is my server that can resolve .local
nameserver 208.67.220.220 # these are optional, fallback dns servers
nameserver 208.67.222.222
# Too many DNS servers configured, the following entries may be ignored.
nameserver 8.8.8.8
search reddog.microsoft.com

In order to make the system use your preferred DNS resolver instead of localhost, you change the symlink to point to /run/systemd/resolve/resolv.conf instead of /run/systemd/resolve/stub-resolv.conf :

sudo rm -f /etc/resolv.conf
sudo ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf

Immediately after this, resolution of .local started working. no need to reboot or restart any service.

  • I uninstalled Avahi and then followed your steps. That made it for me. Thank you Sir. (Using Ubuntu 18.04 Desktop). – José L. Patiño Feb 5 at 13:09
  • Thank you. This was the answer for me. Why doesn't it "just work" out of the box? – adampski Apr 28 at 22:54
  • what's the difference between your solution and the accepted answer? For both, one can skip the first 2/3 of the answer -- even that is the same :-) – HongboZhu Jun 24 at 12:11
2

For me working way for Ubuntu 18.04 is:

Edit avahi conf:

sudo vim /etc/avahi/avahi-daemon.conf

and change .local to .alocal :

[server]
domain-name=.alocal

then, open resolved.conf:

sudo vim /etc/systemd/resolved.conf

and uncomment and edit Domains:

[Resolve]
...
Domains=yourdomain.local
...

and finally restart services:

sudo service systemd-resolved restart
sudo service avahi-daemon restart
  • In my case I only needed to change Domains in /etc/systemd/resolved.conf (and restart the service). – tokosh Nov 12 '18 at 1:55
  • 2
    This didn't do it for me. still nothing – FalcoGer Nov 27 '18 at 13:14
  • Same version of Ubuntu. Using openvpn. This solution works well with VPN on many machines in my team. – razvanone Mar 22 at 8:00
2

What worked for me was adding the local DNS as a nameserver to /etc/resolvconf/resolv.conf.d/head (as described here).

  1. Install the resolvconf package.

    sudo apt install resolvconf
    
  2. Edit /etc/resolvconf/resolv.conf.d/head and add the following:

    nameserver 8.8.4.4  
    nameserver 8.8.8.8  
    
  3. Restart the resolvconf service.

    sudo service resolvconf restart
    

The fix should be permanent.

  • The head file contains a warning not to edit the file, because it is generated by resolvconf? – John Mee Jun 24 at 6:30
  • @JohnMee The head file is the source used to generate /run/resolvconf/resolv.conf. However, I wouldn’t edit this file, too. – Melebius Jul 1 at 8:35
0

My situation was similar but somewhat different: We use server names like myserver on Windows but this did not work on Ubuntu 16.04 and I had to use myserver.mycompany.local. After upgrading to 18.04, I got the following behavior:

$ ping myserver.mycompany.local
ping: myserver.mycompany.local: Name or service not known

$ ping myserver
PING myserver.mycompany.local (192.168.x.y) 56(84) bytes of data.
64 bytes from myserver.mycompany.local (192.168.x.y): icmp_seq=1 ttl=62 time=3.05 ms
...

I simply had to replace myserver.mycompany.local with myserver in my applications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.