1

I read https://help.ubuntu.com/community/VNC/Servers to configure vino server on my ubuntu 16.04.LTS desktop.
Using other vnc servers, I used to connect to 129.254.xxx.yyy:1 (when the vnc session is 1. I can set the port).
But with this vino server, from my vnc client on my windows10 machine, what am I supposed to connect to? how do I know the port number?
I tried vnc to 129.254.xxx.yyy:1 but didn't work.
picture below is the response seen from the client when I tried to connect to 129.254.xxx.yyy:1 but failed.
My setting on my ubuntu 16.04 looks like this :

enter image description here

and my response at the client side(Real vnc client, on windows 10) when I tried 129.254.xxx.yyy:0 is like this

enter image description here

and the message I saw when I tried 129.254.xxx.yyy:1 is like this

enter image description here

and the message seen at the server side (for the two incidents) is like this

enter image description here

What should I change at the settings?

ADD :
After posting this question, I read http://ubuntuhandbook.org/index.php/2016/07/remote-access-ubuntu-16-04/ and turned off the encryption using dconf-editor. When I connect to 129.254.xxx.yyy:1, I finally got connected and could use the vnc for maybe a minute? but then the connection was closed by the server. I don't know what the problem is.

1

I figured it out. the gsettings set org.gnome.Vino require-encryption 'false' command doesn't work in my ubuntu16.04 version and I had to install dconf-editor and setthe remote desktop encryption there. I used 129.254.xxx.yyy:0 to connect.
During a trial I wanted to mve the server to background so I pressed ctrl-Z (thinking I would give a 'bg' comand immediately) but this maded vnc connection stall. That's why I saw 'connection refused by the server' message.
So whey you start the server , place empersand at the end like /usr/lib/vino/ino-server &. Now I can use vnc for my new machine using Unity desktop environment. (That's why I started with vino)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.