5

I'm currently running Ubuntu 18.04 on MSI GS65, running into what seems to be a persisting age old issue:

WIFI IS DISABLED BY HARDWARE SWITCH AFTER SUSPEND

only can comeback up after reboot.

sudo rfkill list all shows

0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes

I've tried the following methods so far, and nothing has worked for me

  1. Hitting the fn+f10 (f10 has a airplane icon on it) doesn't work

  2. rfkill unblock all

  3. I only tried manually restart network manager service as described in this post. Did not implement the script since it didn't work manually Wifi doesn't work after suspend after 16.04 upgrade

  4. tried black listing the msi_wmi module as described in this post How to unblock something listed in rfkill?

  5. manually restart the driver as described in this post. I didn't try the script because it didn't work manually. And also because there isn't anymore folders after my /lib/systemd/system-sleep/ . I'm pretty new to ubuntu, so I wasn't sure what to do. (Yet another) Wifi issue after suspend in Ubuntu 16.04

4

I downgraded to Ubuntu 16.04, however had the same problem. I found the solution. Essentially enabling the airplane mode key on my system.

credit to Gibbsoft Wifi Hard Blocked After Suspend in Ubuntu on GS65

  1. $sudo nano /etc/default/grub
  2. add to the bottom of the file and save

    GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi='Windows 2009' quiet splash"

  3. $sudo update-grub
  4. reboot

now i press fn + f10 (airplane mode key) to enable wifi after suspend

  • Still after the wake up I have to press "Airplane mode" two times. Thanks, It is ok as a workaround, however I'll will look around for another solution. – Nick Linker Nov 24 '18 at 21:02
  • 1
    An alternative that I found was good was using hibernate instead of suspend. I dont get this problem if i use hibernate. I followed this guide to enable hibernate for me – Richard Nov 25 '18 at 22:43
1

If anybody stumbles upon this and has a dual-boot Windows 10 GS65, these instructions may not work. These instructions are meant for GRUB, I setup my laptop to boot using EFI.

Try

sudo kernelstub -a "acpi_osi=! acpi_osi=\"Windows 2009\""

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.