2

Thanks in advance for helping me figure out this strange problem I've had since upgrading from 16 to 18.04 -- I run Wayland now, and I love how much better it is at handling multiple monitors on my hi-dpi laptop (Lenovo Yoga 2nd gen). (Wayland was broken/would not run on 16.04, which was my main reason for upgrading to 18. It seems to work great now.) I'll stick with Wayland even if I can't fix this, because it's worth it to have my display resolutions working properly...but it is mysterious and annoying!

Shortly after the upgrade, I noticed that my lock screen is...broken...ish. Here are its behaviors:

  • It does not automatically lock at all, even though in Settings it's set to lock after 5 minutes. I can leave it for hours and come back and it'll still be wide open.
  • It WILL lock if I select the "lock" icon from the tray-menu (battery icon) -- but it shows the blank purple login screen, even though in Settings I have it configured (like my previous install) to use a wallpaper on the lock screen.
  • The keyboard shortcut I set up (and confirmed is still set after upgrade) to lock the screen does nothing now. This always worked before, and I've tried several different key-combos in case there's some weird conflict, but no keyboard shortcut will work to lock the screen.

I have dconf editor, and I've looked through every setting to do with the lock screen and made sure that it's enabled (though notifications by programs on the lock screen are not; I always turn those off). All the settings in dconf agree with the regular Settings, so nothing looks weird there to me. I use the Caffeine extension to keep the screen from dimming (maybe that's not necessary anymore, in 18, but in gnome-shell on 16 I could NOT shut this off via the settings, hence the Caffeine -- but it never interfered with my lock screen before) -- but I see the same behavior now whether Caffeine is enabled or not, so I assume that's not the problem. One other potential cause, though, is that I had Gnome-Shell extensions installed on 16.04, and now that I've upgraded, they still seem to be there and running...I haven't noticed any other problems, so I've left them; they seem to still work (custom corners and whatnot) and I haven't noticed any other problems, and none of them are related to lock screen specifically...but maybe running gnome-shell extensions on Wayland causes problems? I couldn't find anything on this, though.

Any guesses would be super helpful! I'll be sure to update when I figure out what's going on here.

  • My lock screen is terrible as well, I want to get rid of it completely. I've been able to get rid of the password part all right, but the image with the time still comes up, and then it takes ages to clear. Maybe this works well on a fast computer but most of the world doesn't have a fast computer! I've given you a thumbs up.. I hope your get your answer some day! – Rabbit Sep 9 '18 at 10:30

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.