5

This browser crashes my entire system on a regular basis and absolutely has to be removed.

It does not appear in Software Center.

Running

sudo apt remove chromium-browser

tells me that it is not installed.

Yet it is sitting right here, totally on my system.

I was fairly sure I installed this through the Software Center but see nothing of Chromium under "installed," under any subheading. Searching it out actually offers a second installation.

Next I tried using

sudo apt remove chromium-browser

but am told

Package 'chromium-browser' is not installed, so not removed.

Running the code you asked me to run outputs:

$ type chromium-browser
bash: type: chromium-browser: not found

I even tried using a Debian command I can not recall which ended with -r chromium though I am positive it was not installed that way.

Sorry for failing to edit properly, think I read you right this time.

6
  • Can you remember how did you install it? Please edit your question to add the output of the command type chromium-browser. Don’t forget to apply code formatting.
    – Melebius
    Commented Aug 22, 2018 at 9:17
  • 1
    What did you try so far other than apt remove? What about the answers in this question: askubuntu.com/questions/327023/… ?
    – pLumo
    Commented Aug 22, 2018 at 9:18
  • 1
    Thank you for the update. Can you even launch Chromium? How do you do it? It doesn’t look like the system has any idea about it. If it’s a desktop shortcut, please paste the contents of the *.desktop file into your question. “I even tried using a Debian command I can not recall which ended with "-r chromium"…” Probably dpkg -r? However, if it were installed using dpkg, APT would know about it.
    – Melebius
    Commented Aug 22, 2018 at 9:54
  • 4
    Actually RoVo your linked question got me thinking, how they could still launch from terminal... I tried to do that and was told it was not installed. Then I remembered I could edit the menu items, so I looked at where the launcher command went, and it was indeed in the snap folder. So I did snap help, and then snap remove chromium.... it actually worked. It's gone, not sure why it was overlooked by the Software Center. Melebius and RoVo I hope helping people is making your lives better, be well!! Commented Aug 22, 2018 at 9:55
  • 1
    @adam Glad you got it sorted! You can post an answer, which will help anyone else who has the same issue. (Yes, you can answer your own question.)
    – wjandrea
    Commented Aug 23, 2018 at 3:53

1 Answer 1

12

I see what you speak about. I had an issue like this: I installed Chromium from software center and could not uninstall it. The thing is that it was a snap package (don't ask me why) so you can't remove it with apt or dkpg The solution to your problem is

sudo snap remove chromium 

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .