7

I just installed Ubuntu 18.04 and one of my first negative impressions is the long animation of flying-in icons when opening the app menu.

Can I speed this up or disable it?

10

Yes, it is possible.

This link shows you how

The link shows you how to turn off all kind of animations especially the spreading icons on menu, searching, and window animations so you can work faster. To do it, just run this command:

$ gsettings set org.gnome.desktop.interface enable-animations false

Then apply it by pressing Alt+F2 and type r and press Enter. This will reset the GNOME Shell to follow your command.

To revert it back (enable animation again), just change the command to:

$ gsettings set org.gnome.desktop.interface enable-animations true
2
  • 1
    Link only answers are discouraged on Ask Ubuntu. Adding the main steps required to solve the issue would greatly improve the answer and probably help earn some magical rep points. – Arronical Aug 22 '18 at 8:45
  • 1
    @Arronical Post amended as suggested to include the essential elements of the link. – 24601 Aug 22 '18 at 9:07
9

If you're annoyed by only the "Show Applications" animation, you can disable it by running the following in Terminal

gsettings set org.gnome.shell.extensions.dash-to-dock animate-show-apps false

If you want to get rid of all the GNOME shell animations, run the following instead

gsettings set org.gnome.desktop.interface enable-animations false

You can also speed up GNOME shell animations following this: How do I change the speed of the app drawer appearing?

1
  • 2
    This should be the solution to OPs request, as it disables only the animation when opening the app menu. Most solutions disable all animations and leave you with a desktop experience from the early 2000s. – riker09 Oct 23 '19 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.