1

I am trying to turn off syntax highlighting in Geany.

I tried commenting this out in filetype_extensions.conf.

Sh=*.sh;configure;configure.in;

As a temporary fix, I changed file extension of files such as scripts to txt.

3

The default syntax highlighting colours are defined in /usr/share/geany/filedefs/filetypes.common in the section named

[named_styles]

You can edit/remove one or more but while some are intuitive as colors like

comment=0xd00000

there are some that are a bit weird, like

selection=0x000000;0xc0c0c0;false;true

and I have no idea what they really mean. So it's a case of trial and error, but you can get to a simple white on black theme eventually by removing them.

If you just wanted to disable syntax highlighting for certain file types, there is a mechanism which allows you to overwrite the themes for each file type, but it's tedious. The individual file type configuration files are in the same directory.

But for your purpose, you just want to hack the [named_styles] section in the common conf file which will nuke syntax highlighting in all file types.

EDIT: The other method suggested to you, i.e. removing the file extension from Menu->tools->configuration files->filetype_extensions.conf will have the effect of removing all functionality the ide provides for those file types, while the method I suggested directly affects only the syntax highlighting. But it's up to you which method you adopt, depending on your ultimate goal is.

2

Rather than renaming your .sh scripts with an .txt extension there is a more conventional way to remove syntax highlighting:

Edit Menu->tools->configuration files->filetype_extensions.conf and remove the *.sh; entries.

  • Removing the *.sh entries did not work. @WinEunuuchs2Unix – fixit7 Aug 22 '18 at 3:09
  • The link also refers to one user having to set none as well. – WinEunuuchs2Unix Aug 22 '18 at 3:10
  • I have all syntax turned off except any thing in double quotes. @nobody special You are right, Geany is weird. – fixit7 Aug 22 '18 at 14:10
  • Send email to one of Geany's authors. – fixit7 Aug 22 '18 at 15:19
  • To turn off syntax highlighting just for .sh files set string=default in filetypes.sh – fixit7 Aug 22 '18 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.