0

I just installed Ubuntu Studio 18.04.1 and I experience some a massive mouse lag after a while (this question) This happens with 4.15 lowlatency kernel Ubuntu Studio is shippped with. Since I ran out of ideas and wanted to try the generic kernel I installed 4.15.0-20 headers and image. I can boot, but I won't get full resolution on my screen and WiFi device is not available.

How come? Which extra packages do I need to install or remove in order to get this working?
In both of my last OSs Ubuntu 14.04 and Ubuntu Studio 14.04 I had several generic, lowlatency & rt-preempt kernels installed, and switching between them never was an issue.

Devices:
RTL8188CE 802.11b/g/n WiFi Adapter
AMD Radeon HD 6620G graphics adapter (default driver, only LVDS screen used)

Edit I tried all generic kernels up to 4.15.0-32 to no avail..

0

Open a terminal with Ctrl+Alt+T. After the $ prompt type:

sudo apt update
sudo apt upgrade

Your kernel should be automatically updated to the most recent version 4.15.0-32 I believe.

If you see messages the new kernel is installed, you can activate it by rebooting so type:

sudo reboot

If you don't get the most recent kernel installed post a comment below.


NOTE: I've had bad luck with the 4.15 kernel chain on my laptop (Skylake), eg won't suspend, occasional keyboard 5-10 second freeze and won't suspend with three monitors. So I'm using 4.13 kernel chain instead.

  • That apt/apt-get move wouldn't work for me. I tried pretty much all 4.15 kernels from the official repo (via Synaptic), they suffer the same bug. And the repos don't offer 4.16 kernels, that's why a hint to kernels source might help others. – ronso0 Sep 17 '18 at 23:59
  • @ronso0 Sorry I'm confused by apt move or apt-get move I don't know anything about those two commands... Some kernels are broken for apt remove and apt-get remove for the last few months but a fix is in for that. (apparently). Is that what you are referring to? – WinEunuuchs2Unix Sep 18 '18 at 0:35
  • "move" refers to some kind of apt/apt-get "action" like `apt-get update && apt-get upgrade. sorry for the confusion.. – ronso0 Sep 19 '18 at 6:02
0

I got WiFi and graphics working with 4.16.0-041600-generic headers & image from http://kernel.ubuntu.com/~kernel-ppa/mainline/

For some reason (I don't have time to investigate) 4.15.0-x-generic has problems with realtek and amd gpu drivers on my machine(1), whereas 4.15.0-x-lowlatency works out of-the-box

(1) Thinkpad Edge 525 12003NG

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.