0

I've tried many solutions online.. plz help me.. PC is Lenovo y7000. Dual-boot with ubuntu 16.04.

Key Issue:

  • Network manager not showing wifi like this: (not my pc, but almost same) Network Manager Screenshot.

  • I can detect the wlan called "wlp7s0" in iwconfig/ifconfig, I can even scan available wifi using "sudo iwlist scan", but cant connect one though.

  • Ubuntu Wireless Info Here

  • My linux kernel is v4.15.0-32. Seems v4.14 starts support R8822be. And I did find rtl8822befw.bin in /lib/firmware/rtlwifi . (see this)

Solutions I have tried:

  • Install/Reinstall/Rerereinstall things like bcmwl-kernel-source, firmwares, rtl88x2BE drivers, rtlwifi-new..
  • Update/Upgrade apt.
  • Edit /etc/network/interfaces and restart NetworkManager.
0

This will be a multi-part answer as we will probably have to fix several issues before we locate the underlying problem. I will add edits to this answer as we go.

First, bcmwl-kernel-source is a driver for Broadcom devices. Yours is a Realtek and so it isn't needed. Let's remove it. From the terminal:

sudo apt-get purge bcmwl-kernel-source

Next, your changes to /etc/rc.local will be ineffective. Please remove them:

sudo nano /etc/rc.local

Remove your changes so that the only uncommented # part is:

exit 0

Proofread carefully, save (Ctrl+o followed by Enter) and exit (Ctrl+x) the text editor.

Next, when you add an interface to /etc/network/interfaces, then Network Manager steps aside so that you may manually configure the interface. Your addition to the file is defective in that the interface will not connect without knowing the SSID and WPA2 password. Moreover, in only a very few cases in my experience, will Network Manager not do the job as well as interfaces. Let's remove the defective stanza.

sudo nano /etc/network/interfaces

Remove these lines:

auto wlp7s0
iface wlp7s0 inet dhcp

Proofread carefully, save and close the text editor.

Reboot and tell us if there is any improvement. Then please run and paste a new Wireless Info as above. Paste it here and give us the link: http://paste.ubuntu.com

EDIT: You also need to blacklist ideapad_laptop. From the terminal:

sudo -i
echo "blacklist ideapad_laptop"  >>  /etc/modprobe.d/blacklist.conf
modprobe -r ideapad_laptop
exit

Any improvement? It may take a reboot.

  • Thanks for your help! I did all you said and rebooted. Wireless info. Looks like nothing changed except scanning down. I have to explain that changes in rc.local were because of Lenovo ideapad block wlan Like this – Vitech Aug 22 '18 at 12:43
  • The link you gave suggested that the module be blacklisted. I agree. However, you added a faulty sequence to rc.local instead. Please see my edit in a few moments. – chili555 Aug 22 '18 at 13:56
  • This reboot stucked at Ubuntu purple screen (Terminial hangs at "Ubuntu started show playmouth booting screen"). I waited so long and have to force shutdown and reboot goes well. Still no wifi. Wireless info lost wlp7s0 in ifconfig. Paste Bin. – Vitech Aug 22 '18 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.