0

I have a trouble installing VirtualBox after updating to Ubuntu 18.04. I am aware that there are other questions relating to the similar issue, but following solutions on the forums did not work.

I previously had Ubuntu version 16.04 and did have trouble installing VirtualBox. This was solved by following the guide from the first link (signing the software). I had updated my OS version to 18.04 recently, and VirtualBox was removed automatically. Reinstallation process is giving me an error similar to the one that I previously encountered, but signing the software did not solve it. I also tried other methods in the forums, but there was no luck.

Kernel Version: 4.15.0-32-generic

VirtualBox Version: Version 5.2.18 r124319 (Qt5.9.5).

I've installed VirtualBox from two different sources. One is from the terminal by adding a repo using the instructions here. I've also tried installing using .deb file downloaded from the official website. (AMD64 version for Ubuntu 18.04) Currently running the one from the repo.

Description of the error

The software is installed properly, but when I try to run a virtual machine, it gives me the following error.

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/sbin/vboxconfig'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Running sudo /sbin/vboxconfig gives me the following messages.

vboxdrv.sh: Stopping VirtualBox services. vboxdrv.sh: Starting VirtualBox services. vboxdrv.sh: Building VirtualBox kernel modules. vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

There were problems setting up VirtualBox. To re-start the set-up process, run /sbin/vboxconfig as root.

Result of dmesg

[ 1284.290329] systemd: 48 output lines suppressed due to ratelimiting
[ 1284.296874] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[ 1284.315287] systemd[1]: Detected architecture x86-64.
[ 1284.562560] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[ 1284.563136] systemd[1]: Detected architecture x86-64.
[ 1284.774470] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[ 1284.774754] systemd[1]: Detected architecture x86-64.
[ 1284.837786] systemd[1]: Started CUPS Scheduler.
[ 1284.837916] systemd[1]: Started ACPI event daemon.
[ 1285.032635] systemd[1]: systemd 237 running in system mode. (+PAM +AUDIT +SELINUX +IMA +APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN -PCRE2 default-hierarchy=hybrid)
[ 1285.033048] systemd[1]: Detected architecture x86-64.
[ 1285.100518] systemd[1]: Started ACPI event daemon.
[ 1285.299925] systemd[1]: Started ACPI event daemon.
  • 1
    Please add which kernel version you use, as well as wether you got the default one or from a PPA, and which virtual box version you use. Your kernel version may not be suported by that VB version. – spacelander Aug 21 '18 at 6:53
  • @spacelander Thanks for the help. Updated the question with the information. – James Parker Aug 21 '18 at 10:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.