2

Running LightDM w/ 18.04 LTS Desktop. X11VNC is configured correctly and works whenever NVIDIA drivers not installed. Xorg.conf has been configured with nvidia-xconfig with the display none parameter.

Upon boot, I can VNC to the login screen. Upon typing in my password and trying to load into MATE, the login window disappears but the rest of the window remains unchanged. I have noticed that when I successfully VNC to desktop (without NVIDIA drivers), the screen will blink purple (with the 18.04 default wallpaper, if that matters) before loading my desktop. That purple blink does not happen with NVIDIA drivers installed.

There is no problem if the Xorg.conf file is deleted and I connect an actual monitor. There is no problem if I run LXDE headless.

I encountered this problem first with Nvidia driver 396 and regressed to 390 in an attempt to resolve the issue. I have searched on both this website and Nvidia's dev forum for help, but the only hints I've gotten is that installing .run drivers with --no-opengl-files might conceivably have an impact on the outcome; but other posts indicate X11VNC doesn't care about OpenGL.

The card in question is a GTX 1070.

If anyone has any idea how to load MATE onto a headless server with Nvidia drivers, let me know!

  • Same here. Any progress? – fx-kirin Aug 29 at 1:56
  • I switched over to NoMachine. Comes with its own problems, though. – A.Y. Aug 30 at 5:36
0

Ditto with regular Ubuntu 18.04 and 1080TI also with lightdm. I tried every permutation of options supplied to x11vnc to no avail. Used to work gloriously on 16.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.