2

I currently have and use the official Cisco AnyConnect Client.

When I connect to it all it asks me for is my username and password.

When I try to connect to the same server using the package from network-manager-openconnect-gnome it looks like this:

Add VPN dialog

  • Why are there so many options (Certificate, proxy etc.)?
  • Why can't I connect with only a username and password like on the official client?

With the AnyConnect client all I need is the username and password. I do not even have a cert for this VPN.

  • How can I simplify this?

Update: The network-manager-vpnc-gnome looks better (i.e. fewer options) but it still asks for options I do not have (group name and group password): enter image description here

The official client is so much simpler.

  • You can try network-manager-vpnc-gnome for comparison. It does not require certificate, but allows to connect to Cisco VPN. – N0rbert Aug 21 '18 at 7:20
  • @N0rbert this looks better (fewer options) but I still can't add the VPN until I enter a "group name" which again the official Anyconnect client does not ask for (and I do not have it). – Startec Sep 2 '18 at 22:11
  • try this: sudo apt install openconnect network-manager-openconnect network-manager-openconnect-gnome – gdbdable Dec 6 '18 at 7:20
2

With the openconnect network manager integration, all you really need is the gateway address - you also need that when you use the Cisco client. You can leave all other options at their defaults. When you connect, it'll ask for your username and password. (Tested on 18.10)

| improve this answer | |
  • Thank you. I had a similar setting with NetworkManager on kde, openconnect plugin, on Centos 7. Just input the gateway address and then I was able to connect with user and password. – Michele Piccolini Mar 10 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.