I recently installed Ubuntu 18.04 on my new computer (Asus-ZenBook-Pro-15-UX580GE-BO022T) and everything seems to works fine except my touchpad. After installation and first reboot the tochpad was working. I then changed additional drivers to use nvidia-driver-390 instead of xserver-xorg-video-nouveau. When changes were made and i rebooted the computer tocuhpad wasn't working anymore. (I have tried to change back to xserver instead of nvidia without luck)

xinput gives me:

~$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ELAN Touchscreen                          id=12   [slave  pointer  (2)]
⎜   ↳ Lenovo Optical Mouse                      id=13   [slave  pointer  (2)]
⎜   ↳ GDX1505:00 27C6:01F1 Touchpad             id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
↳ Power Button                              id=6    [slave  keyboard (3)]
↳ Video Bus                                 id=7    [slave  keyboard (3)]
↳ Video Bus                                 id=8    [slave  keyboard (3)]
↳ Power Button                              id=9    [slave  keyboard (3)]
↳ Sleep Button                              id=10   [slave  keyboard (3)]
↳ ELAN Touchscreen Pen                      id=11   [slave  keyboard (3)]
↳ USB2.0 VGA UVC WebCam: USB2.0 V           id=14   [slave  keyboard (3)]
↳ Asus WMI hotkeys                          id=16   [slave  keyboard (3)]
↳ AT Translated Set 2 keyboard              id=17   [slave  keyboard (3)]

As you can see there is a touchpad as input device. And when i go to Settings->Devices->Mouse & Touchpad the touchepad is enabled and everything looks fine. On the other hand, when i click fn + f6 (enable/disable touchpad) there is a cross over the touchpad icon. No matter how many times i click, I can't enable it from here.

Hope you guys understand my problem. Tell me if you need more information.


I also had touchpad problem with my ASUS notebook (fx553vd).

Updating kernel fixed my problem (4.17rc6, 4.18+ touchpad works).

You can find new kernel versions here

  1. Select specific kernel you want to use
  2. Download headers_all.deb,headers_generic.deb, image_generic.deb, module_generic.deb files
  3. If your download folder is empty, do next: cd /Downloads, sudo dpkg -i *.deb. Else do next: cd /Downloads, mkdir newkernel, mv (here you have to specify each .deb file) newkernel, sudo dpkg -i *.deb

After updating kernel, go to Keyboard -> Mouse & Touchpad -> Touchpad ON.

I hope I helped you.

  • I did what you said and updated the kernel. The touchpad is still not working though. The first reboot after updating the kernel the touchpad was working. Next startup it was dead again. – user3249677 Aug 26 '18 at 9:47
  • Do you boot with specific grub parameters? If you do, clear them, and try again. And are your graphics drivers installed? If they aren't it also can affect the problem. – V. Dalechyn Aug 26 '18 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.