2

I can't get my Brother HL 2270 DW printer to work wirelessly in 18.04, from a clean install on a Dell XPS 13 9360. I've tried for hours, days, using all the methods I can find in various forums, including going through CUPS, installing the Brother drivers via the terminal. Even worse, I don't know what IPP means, or DHCP, or PPD, or CUPS. It's pretty excruciating, as I increasingly find Linux to be, after having children and not having anymore the spare hours to find solutions for simple things. (Apologies for expressing frustration!).

I reset the network on the printer, can print via USB connection, but even when I get the printer to appear in my DHCP client list (via TPLink router), I can't ping it from my PC.

Any advice for an ignoramus?

2
  • I have that printer and after downloading the driver from Brother it can be pretty smooth. 1) Which desktop are you using? Ubuntu,Xubuntu,MATE...?; 2) Where did you get the driver; 3) How did you install the driver?;4) What process are you using to attach your Ubuntu to the printer? You can google for acronyms. search for "acronym PPD print" and so on. Don't fret, Dad. Getting printers to work can be pretty horrible and the kids DO grow up. All will be well. Aug 21 '18 at 4:09
  • Thanks. 1) Using Ubuntu GNOME; 2) Downloaded from Brother's website "linux-brprinter-installer-2.1.1-1", then tried "hl2270dwlpr-2.1.0-1.i386.deb" and "cupswrapperHL2270DW-2.0.4-2.i386.deb"; 3) installed the first in the list above using bash in terminal 4) I used the WPS feature on the router and printer, after which the printer showed up as a DHCP client in my router admin tool (it no longer does, though), and I was able to add the printer through the wizard in settings>devices>printers. Never was able to actually print wirelessly, though.
    – troodon
    Aug 22 '18 at 14:10
0

If you can print via usb; that would suggest the brother drivers are installed; if you go to the PRINTERS folder; click the ADD button; pause; (with the usb cable disconnected); does the system "find" your 2270? __ to run the brother installer tool, get it from here http://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=hl2270dw_all&os=128&dlid=dlf006893_000&flang=4&type3=625 and click to download and SAVE what will be linux-brprinter-installer-2.2.0-1.gz

open a terminal; copy each commmand; paste it into the terminal; hit the ENTER key to make it happen;

cd Downloads

gunzip linux-brprinter-installer-2.2.0-1.gz

sudo bash linux-brprinter-installer-2.2.0-1 HL-2270DW

it will show a list as it works; and ask you which uri you want; it is usually what is shown in number 10

7
  • Thanks. Yes, I was able to use the "add" button to find the printer. It seemed all set up, without having used the USB connection yet, but printing yielded a status of "unable to locate printer."
    – troodon
    Aug 22 '18 at 14:14
  • if you open a terminal and type or paste dpkg -l hl2270* can you copy the result and paste it back here please; and also what does lpinfo -v give in a terminal please
    – pdc
    Aug 22 '18 at 20:53
  • Sorry, I don't know how to do the formatting here, but the results are:jmp@Violet:~$ dpkg -l hl2270 dpkg-query: no packages found matching hl2270 jmp@Violet:~$ lpinfo -v file cups-brf:/ network ipp network http network beh network lpd network socket direct hp network https network ipps direct hpfax jmp@Violet:~$
    – troodon
    Aug 23 '18 at 2:46
  • so doesn't seem like you have brother drivers installed; if I detail above in the previous answer
    – pdc
    Aug 24 '18 at 8:19
  • OK, I followed the steps, still can't ping the printer or print, even though the printer seems to get installed (shows up in the printers tool). I tried a couple times, uninstalling the printer first before each attempt. The option referred to as number 10 in the uri step was different (once it was specify an ip address, once it was a printer identification string with dnssd). Sorry I can't be more specific, but I don't understand these things. Probably should not be using Linux, but it's been 6 years now!
    – troodon
    Aug 25 '18 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.