8

I just installed Ubuntu 18.04. (In dual boot) The speakers are recognized in settings: it says "speakers - built-in audio" under Settings-Sound. However, they do not work. Headphones do work for system sounds and in Chromium, but they do not work in Firefox.

Any other information, please ask. I am new at this and don't really know what is necessary to give.

This worked for a few days, but then it stopped working: I turned off fast startup on Windows following No sound from laptop speakers in Ubuntu 14.04 after booting into Windows 8.1. Now my speakers are working except on firefox: so now the only problem was that neither the speakers nor the headphones work with firefox. Using pavucontrol as in https://askubuntu.com/a/822196/679786 I managed to get the sound right in firefox too.

But now the problem is back.

4
  • Is your system in a dual-boot configuration?
    – velix
    Aug 20, 2018 at 17:19
  • @velix Yes, it is.
    – Soap
    Aug 20, 2018 at 20:50
  • 1
    I have a problem in a dual boot with Windows. If I reboot from Windows (when audio is working there) i get no audio in Ubuntu and vice versa. To switch from an OS to another without losing audio I have to perform a complete shutdown. Try yourself, may be a problem similar to mine.
    – velix
    Aug 21, 2018 at 9:57
  • @velix Thanks for the suggestion, but it didn't work
    – Soap
    Aug 21, 2018 at 13:56

4 Answers 4

6

I had this same problem and it was driving me nuts trying to fix it because whenever I booted into Windows 10, sound worked fine. Meanwhile, on Ubuntu 18.04, I found a number of helpful web pages with suggestions for troubleshooting audio problems.

The suggestion that worked for me was running 'sudo alsamixer' in a terminal window. I didn't even have success with this until I started to approach the problem with the expectation that things were gonna work realized I needed to be able to tell when they did.

I have provided some very basic instructions below that I hope might help someone troubleshooting audio problems. While steps 3 and onward are specific to alsamixer (version 1.1.3), steps 1 and 2 may help a person detect when things are working for other changes. If you are already familiar with alsamixer, then I'm sure you will understand that we are looking for any playback settings that may be muting output or producing output at a volume to low to be heard. In my case, it was the muting of one particular item that actually produced audio through the speakers.

  1. Turn speakers on to HALF volume, NOT full volume
  2. Start the audio source you want to hear through the speakers. It is important that the audio source provide continuous test audio so that you will hear the audio through the speakers once the correct setting is discovered and adjusted.
  3. Open a terminal window
  4. Enter the following command: sudo alsamixer
  5. Assuming the application launches and you can see the UI, proceed with the remaining steps.
  6. Press F6 to select the desired soundcard
  7. Press F3 to ensure we are only exploring [Playback] settings

We're gonna change the volume level or mute status of various items to see if the change causes audio to come through the speakers. The currently selected item is the one on the left. By moving the right arrow key we can select the item to its right. We will slowly explore each item until we go all the way to the right. You will see the name of the currently selected item appear in the upper right of the screen next to "Item:"

  1. Use the right and left arrow keys to move to different items.
  2. Note the current volume level or mute status.
  3. If the item volume indicator has a little box with "MM" or "0", try toggling the mute status with the "M" on the keyboard. If you do not hear audio from the speakers, then toggle the item again to put it back to its original state.
  4. If the item volume has a vertical box, use the up and down arrow keys to raise the volume level all the way to the top. If this does not result in audio being output from the speaker, then lower the volume back to its original value.
  5. Repeat steps 7 through 10 until you hear the test audio from the speakers or until you reach the last item on the right.

My apologies if you get all the way to the right without any improvement in your audio configuration.

In my case, I have an ancient Creative Labs SoundBlaster Audigy 2 ZS sound card. Everything worked right out of the box when I first installed Ubuntu, but some later actions on my part broke the audio configuration to where I could hear audio through headphones but nothing came through the speakers, even if I physically disconnected the headphones (which I also tried since some cards auto-toggle speakers when headphones are connected/disconnected).

When I followed the steps above, I came to the item: Audigy Analog/Digital Output Jack, which was set to "0" (enabled), I toggled to mute ("MM"), thereby turning the item "[Off]". The moment I did this, I actually got sound output through the speakers. Makes no sense to me at all why enabling this item would DISABLE output to speakers and vice-versa, but I'm so happy to have finally found this setting and fixed my audio configuration, and can now listen through speakers or headphones as I choose.

1
  • Thank you for this guide. It actually worked for me. Funny though, when I unmuted Headphones and increased volume, the sound came through the speakers. Apr 4, 2019 at 16:26
2

Had the same with either Ubuntu 18.04 or 20.04 on HP laptop (dual boot Win10) : Sound over HDMI [1] and headphone is OK, but no sound on builtin laptop speakers.

I finally notice that:

  • cold start with Ubuntu : sound will work on builtin speakers! Switching to HDMI then Headphone then back to builtin speakers will be OK too.
  • cold start with Win10 then restart on Ubuntu leads to no sound on builtin speakers. I will have to power off, then start Ubuntu to have sound on builtin speakers.

Seems that Win10 intel sound driver locks something with the hardware that is surviving after restart.

[1] Driver setup :

  • nvdia v450.66 from nvidia-driver-450 (proprietary) (This is to get HDMI support with sound/hdmi)
1
  • Turns out this is exactly how it works for me as well. Thanks.
    – Gino
    Dec 24, 2021 at 4:16
1

I have had the same issues dual booting where it works fine on windows what I found to work recently besides unplugging and plugging in while having constant audio is to toggle mute unmute for all the items in alsamixer. The one that was causing issues for me was S/PDIF

Hope that helps and best of luck to all!

0

Had the same issue with ubuntu 18.04 with a dual booted win 10.

None of the alsamixer/pavucontrol troubleshooting worked for me. The issue reproduced always the same way. I start playing any audio, it starts first then quickly within a second fades out. Changing alsamixer settings doesn't help. Reinstalling drivers didn't help.

I even edited the pulse audio config (for me /etc/pulse/default.pa) and commented out this line to disable suspend pulseaudio if its idle for too long. (restart after with pulseaudio -k)

#load-module module-suspend-on-idle

Still didn't work. After almost 1 year suffering with the issue (i often use headphones and the audio works that way so I was able to live with it), later I realize the pattern. The sound didn't work only when I switched to ubuntu by restarting or sleeping/suspending from windows and booted into ubuntu etc.

If you have windows with dual boot alongside ubuntu, than you must shutdown the windows OS properly. Restart/suspend/sleep those options will cause sound not to work. Only shutdown! Then boot up in ubuntu, the sound works flawlessly.

If it is not a dual boot situation, I believe the other suggestions for troubleshooting with pauvocontrol/alsamixer etc should work.

I don't know how the sound drivers in the latest laptops works but seems like something static is retained in them from windows 10 which causes this.

My pc: Asus Q536D laptop
Sound Card: HDA Intel PCH
Chip: Realtek ALC294 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.