7

I'm using Kbuntu and when I turn on my computer and log in, the default app KTorrent automatically starts up and opens a window on my desktop. I want KTorrent to open up when I manually select the application from the start menu. I check in the Ktorrent settings and I don't see an option, nor in the Autostart application, which is empty.

How do I stop KTorrent from automatically starting short of uninstalling the app?

6
  • I don't use kbuntu but run this sudo systemctl list-unit-files | grep -i ktorrent and lets see if it's there it should be. If there disable with sudo systemctl disable ktorrent, now it won't start at boot Aug 19 '18 at 19:59
  • 1
    Open System Settings > Startup & Shutdown > Desktop Session and try Start with an empty session in the On Login section. Log out and log back in.
    – DK Bose
    Aug 20 '18 at 1:52
  • @GeorgeUdosen thank you very much, that works!
    – Smeterlink
    Aug 14 '19 at 14:10
  • @smeterlink let me post an answer so you can accept it! Aug 14 '19 at 15:38
  • @GeorgeUdosen I just disabled session restore. For some reasons I close ktorrent before shutting down but keeps opening it again if session restore is enabled.
    – Smeterlink
    Aug 15 '19 at 22:32
7

When you close ktorrent, it's still running in the system tray. If you have "restore previous session" enabled in the System "Startup and Shutdown" settings, KTorrent will be re-started in windowed mode, even if it was minimized to the tray when shut down. ktorrent still running in the system tray System Settings - Restore Previous Session To prevent KTorrent from starting, either

  1. close it by right clicking on it's tray entry and press "Quit". closing ktorrent from system tray
  2. disabling "restore previous session" in System Settings
1

Do two things:

  1. First check to see if it's enabled with the command

    sudo systemctl list-unit-files | grep -i ktorrent
    
  2. Then disable it with

    sudo systemctl disable ktorrent
    

Info:

list-unit-files [PATTERN...] List unit files installed on the system, in combination with their enablement state (as reported by is-enabled). If one or more PATTERNs are specified, only unit files whose name matches one of them are shown (patterns matching unit file system paths are not supported).

4
  • 1
    I have ktorrent installed but does not appear when I run the command sudo systemctl list-unit-files | grep -i ktorrent, maybe it's a ktorrent bug.
    – Smeterlink
    Aug 17 '19 at 23:55
  • I can't find anything with sudo systemctl list-unit-files | grep -i ktorrent
    – Yuvaraj V
    Jan 5 '20 at 5:41
  • check for the binaries with which ktorrent assuming that's what it's called! Jan 5 '20 at 6:32
  • This doesn't make sense for this scenario. KTorrent is not, and does not, install a systemd service.
    – Kurtoid
    Jan 10 '20 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.