0

I upgraded to Ubuntu 18.04 and now cannot connect to wifi. If trying from system menu, I see "Connection failed - Activation of network connection failed". Wired connection is working. Network adapter is Qualcomm Atheros AR9485 but driver is missing in "Software and Updates - Additional Drivers". Here is the wireless info:

########## wireless info START ##########

Report from: 19 Aug 2018 13:50

Booted last: 19 Aug 2018 00:00

Script from: 10 Jan 2018 20:04 UTC +0000

release

Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic

kernel

Linux 4.15.0-32-generic #35-Ubuntu SMP Fri Aug 10 17:58:07 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=1

desktop

Ubuntu

lspci

03:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01) Subsystem: AzureWave AR9485 Wireless Network Adapter [1a3b:2c97] Kernel driver in use: ath9k

04:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0a) Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1043:1587] Kernel driver in use: r8169

lsusb

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 001 Device 004: ID 13d3:5165 IMC Networks Bus 001 Device 003: ID 13d3:3362 IMC Networks Atheros AR3012 Bluetooth 4.0 Adapter Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

PCMCIA card info rfkill

0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no

lsmod

asus_nb_wmi 28672 0 asus_wmi 28672 1 asus_nb_wmi sparse_keymap 16384 1 asus_wmi wmi_bmof 16384 0 mxm_wmi 16384 0 ath9k 151552 0 ath9k_common 36864 1 ath9k ath9k_hw 471040 2 ath9k,ath9k_common ath 28672 3 ath9k_hw,ath9k,ath9k_common ath3k 20480 0 mac80211 778240 1 ath9k bluetooth 548864 34 btrtl,btintel,bnep,btbcm,rfcomm,ath3k,btusb cfg80211 622592 4 mac80211,ath9k,ath,ath9k_common wmi 24576 3 asus_wmi,wmi_bmof,mxm_wmi video 45056 2 asus_wmi,i915

interfaces

[/etc/network/interfaces] auto lo iface lo inet loopback

iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off Power Management:off

resolv.conf

nameserver 8.8.8.8 nameserver 127.0.0.53 search Speedport_W_724V_09071602_00_008B

network managers

Installed:

NetworkManager

Running:

root 882 1 0 13:15 ? 00:00:03 /usr/sbin/NetworkManager --no-daemon

[main] NetworkingEnabled=true WirelessEnabled=true WWANEnabled=true

NetworkManager.conf

[main] plugins=ifupdown,keyfile

[ifupdown] managed=false

[device] wifi.scan-rand-mac-address=no

[ath9k] filename: /lib/modules/4.15.0-32-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko license: Dual BSD/GPL description: Support for Atheros 802.11n wireless LAN cards. author: Atheros Communications srcversion: F4328CE52BA6067DD4EDE7B depends: mac80211,ath9k_hw,ath9k_common,cfg80211,ath retpoline: Y intree: Y name: ath9k vermagic: 4.15.0-32-generic SMP mod_unload signat: PKCS#7 signer:
sig_key:
sig_hashalgo: md4 parm: debug:Debugging mask (uint) parm: nohwcrypt:Disable hardware encryption (int) parm: blink:Enable LED blink on activity (int) parm: led_active_high:Invert LED polarity (int) parm: btcoex_enable:Enable wifi-BT coexistence (int) parm: bt_ant_diversity:Enable WLAN/BT RX antenna diversity (int) parm: ps_enable:Enable WLAN PowerSave (int) parm: use_chanctx:Enable channel context for concurrency (int) parm: use_msi:Use MSI instead of INTx if possible (int)

[ath9k_common] filename: /lib/modules/4.15.0-32-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko license: Dual BSD/GPL description: Shared library for Atheros wireless 802.11n LAN cards. author: Atheros Communications srcversion: 94213E6B06C24095311E862 depends: ath9k_hw,cfg80211,ath retpoline: Y intree: Y name: ath9k_common vermagic: 4.15.0-32-generic SMP mod_unload signat: PKCS#7 signer:
sig_key:
sig_hashalgo: md4

[ath9k_hw] filename: /lib/modules/4.15.0-32-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko license: Dual BSD/GPL description: Support for Atheros 802.11n wireless LAN cards. author: Atheros Communications srcversion: D5984DFEF6457DDB060988E depends: ath retpoline: Y intree: Y name: ath9k_hw vermagic: 4.15.0-32-generic SMP mod_unload signat: PKCS#7 signer:
sig_key:
sig_hashalgo: md4

[ath] filename: /lib/modules/4.15.0-32-generic/kernel/drivers/net/wireless/ath/ath.ko license: Dual BSD/GPL description: Shared library for Atheros wireless LAN cards. author: Atheros Communications srcversion: 555BBBB9D4FCA58A05E7C0D depends: cfg80211 retpoline: Y intree: Y name: ath vermagic: 4.15.0-32-generic SMP mod_unload signat: PKCS#7 signer:
sig_key:
sig_hashalgo: md4

[ath3k] filename: /lib/modules/4.15.0-32-generic/kernel/drivers/bluetooth/ath3k.ko firmware: ath3k-1.fw license: GPL version: 1.0 description: Atheros AR30xx firmware driver author: Atheros Communications srcversion: 36C0F7AEF3B569F1798216D depends: bluetooth retpoline: Y intree: Y name: ath3k vermagic: 4.15.0-32-generic SMP mod_unload signat: PKCS#7 signer:
sig_key:
sig_hashalgo: md4

[mac80211] filename: /lib/modules/4.15.0-32-generic/kernel/net/mac80211/mac80211.ko license: GPL description: IEEE 802.11 subsystem srcversion: 1CEA5CF286EDB289C1D0BF8 depends: cfg80211 retpoline: Y intree: Y name: mac80211 vermagic: 4.15.0-32-generic SMP mod_unload signat: PKCS#7 signer:
sig_key:
sig_hashalgo: md4 parm: minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool) parm: max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int) parm: max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int) parm: beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int) parm: probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int) parm: ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211] filename: /lib/modules/4.15.0-32-generic/kernel/net/wireless/cfg80211.ko description: wireless configuration support license: GPL author: Johannes Berg srcversion: D5B0789D4C423C81CCFB437 depends:
retpoline: Y intree: Y name: cfg80211 vermagic: 4.15.0-32-generic SMP mod_unload signat: PKCS#7 signer:
sig_key:
sig_hashalgo: md4 parm: bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int) parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp) parm: cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

module parameters

[ath9k] blink: 0 bt_ant_diversity: 0 btcoex_enable: 0 led_active_high: -1 nohwcrypt: 0 ps_enable: 0 use_chanctx: 0 use_msi: 0

[mac80211] beacon_loss_count: 7 ieee80211_default_rc_algo: minstrel_ht max_nullfunc_tries: 2 max_probe_tries: 5 minstrel_vht_only: Y probe_wait_ms: 500

[cfg80211] bss_entries_limit: 1000 cfg80211_disable_40mhz_24ghz: N ieee80211_regdom: 00

/etc/modules

lp

coretemp

modprobe options

[/etc/modprobe.d/amd64-microcode-blacklist.conf] blacklist microcode

[/etc/modprobe.d/asus.conf] options asus_nb_wmi wapf=1

[/etc/modprobe.d/blacklist-ath_pci.conf] blacklist ath_pci

[/etc/modprobe.d/blacklist.conf] blacklist evbug blacklist usbmouse blacklist usbkbd blacklist eepro100 blacklist de4x5 blacklist eth1394 blacklist snd_intel8x0m blacklist snd_aw2 blacklist i2c_i801 blacklist prism54 blacklist bcm43xx blacklist garmin_gps blacklist asus_acpi blacklist snd_pcsp blacklist pcspkr blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf] alias net-pf-3 off alias net-pf-6 off alias net-pf-9 off alias net-pf-11 off alias net-pf-12 off alias net-pf-19 off alias net-pf-21 off alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf] blacklist microcode

[/etc/modprobe.d/iwlwifi.conf] remove iwlwifi \ (/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \ && /sbin/modprobe -r mac80211

rc.local

echo 0 > /sys/class/backlight/acpi_video0/brightness

[ -x /usr/bin/numlockx ] && numlockx on

[ -x /usr/bin/numlockx ] && numlockx on

echo 1 > /sys/class/backlight/acpi_video0/brightness [ -x /usr/bin/numlockx ] && numlockx on rfkill unblock all

exit 0

pm-utils udev rules

[/etc/udev/rules.d/70-persistent-net.rules] PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1c.3/0000:04:00.2 (r8169) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth", NAME="eth0" PCI device 0x168c:/sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0 (ath9k) SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?", ATTR{address}=="", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan", NAME="wlan0"

dmesg

[ 35.228340] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 35.635028] r8169 0000:04:00.2 eth0: link down [ 35.635112] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready [ 35.652048] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready (repeated 7 times) [ 38.421786] r8169 0000:04:00.2 eth0: link up [ 38.421806] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready [ 39.035824] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready (repeated 54 times)

#### wireless info END ############
  • See if it will find wifi if it is closer to the router – Jeremy31 Aug 19 '18 at 12:05
0

I have Asus zenbook and the wireless works ok. Note that the wireless interface can appear as wlp2sX instead of wlanX when you use ifconfig -a. You could try the following:

1. Get details about available WiFi networks:

$ sudo iwlist wlp2sX scan

2. Add network to the known wifi networks:

Edit the file /etc/wpa_supplicant/wpa_supplicant.conf:

Go to the bottom of the file and add the following:

network={ ssid="your_ssid" psk="your_password" }

NOTE! Remember the quotation marks (") and the last closing bracket (}).

3. Bring the Wifi interface up

$ sudo ifdown wlp2sX; sudo ifup wlp2sX

Hope this helps!

  • My wifi is already in the network list. Would this solution help again? – silon Aug 21 '18 at 9:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.