3

Everybody knows that any kernel module can be blacklisted via GRUB line:

$ module_name.blacklist=yes

However, not everybody knows the exact name of module to blacklist. And that is the real problem! How to identify it?

For example, during of loading of GRUB I see:

rtlwifi firmware not available

which is quite useless of identification. Neither

rtlwifi.blacklist=yes

nor any other variants worked. How do I figure out the name?

The same thing goes with Bluetooth adapter. It throws:

 [ 9.366503] Bluethooth: hci0: Failed to load rtl_bt/rtl8821a_fw.bin

Of course, rtl_bt/rt18821a_fw.blacklist=yes didn't work.

$ lsmod | grep rtl 
rtl8821ae             233472  0
btcoexist             131072  1 rtl8821ae
rtl_pci                32768  1 rtl8821ae
btrtl                  16384  1 btusb
bluetooth             548864  5 btrtl,btintel,btbcm,btusb
rtlwifi                77824  3 rtl_pci,btcoexist,rtl8821ae
mac80211              778240  3 rtl_pci,rtlwifi,rtl8821ae
cfg80211              622592  2 mac80211,rtlwifi

Any suggestions?

UPDATE: What concerns rtlwifi error lspci -v listed only following

Network controller: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter
Subsystem: ASUSTeK Computer Inc. RTL8821AE 802.11ac PCIe Wireless Network Adapter
Flags: bus master, fast devsel, latency 0, IRQ 29
I/O ports at e000 [size=256]
Memory at f7d00000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [40] Power Management version 3
Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number 00-e0-4c-ff-fe-87-2b-01
Capabilities: [150] Latency Tolerance Reporting
Capabilities: [158] L1 PM Substates
Kernel driver in use: rtl8821ae
Kernel modules: rtl8821ae

And name rtl8821ae already was in my blacklist without any result, so it seems to be no-go.

What concerns Bluethooth: hci0 error, lspci listed no Bluetooth modules or nothing similar to rtl_bt, maybe because Bluetooth adapter is not a PCI device.

  • 1
    What does lsmod | grep rtl tell us? – Jeremy31 Aug 20 '18 at 17:47
  • Added output to question – Suncatcher Aug 21 '18 at 4:33
  • Something is clearly wrong with the blacklisting as rtl8821ae is still being loaded according to your lsmod above (but not used, as it says "0"). It's not clear what the actual problem is though, why you want to blacklist. Is it blacklisted in /etc/modprobe.d ? Try that, reboot, check it's not in lsmod. Are you using bluetooth? – pbhj Sep 3 '18 at 11:06
  • No, I am not using bluetooth. I am trying to boot ubuntu-based Clonezilla image and exclude unnecessary modules. As I know it, it supports blacklisting only via grub.cfgbut I will try /etc/modprobe.d – Suncatcher Sep 3 '18 at 13:25
  • what device are you trying to blacklist? – dfc Sep 4 '18 at 15:48
1

You can boot without blacklisting the driver and then use lspci -v to display the information about the hardware and the kernel driver and module associated with it. The Kernel Modules: section should show module name you need to blacklist (most likely)

Sample output:

00:01.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
    Subsystem: Red Hat, Inc Qemu virtual machine
    Flags: medium devsel, IRQ 9
    Kernel driver in use: piix4_smbus
    Kernel modules: i2c_piix4

Module name in above example is i2c_piix4

Let me know if that works. Source of this info is https://askubuntu.com/a/110343/142100

  • Tried your suggestion without any result. See the details in my update. – Suncatcher Sep 1 '18 at 19:18
  • Does rmmod rtl8821ae do anything after you have already booted. – Fahad Yousuf Sep 17 '18 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.